Patch Watch

If you use IE, don’t — at least not for now

A serious vulnerability in Internet Explorer 6 through 9 has come to light, and there’s no patch at this time. If you must use Internet Explorer for specific applications, use another browser as much as possible and remove or disable Java.

Read More »