Results 1 to 8 of 8
  1. #1
    2 Star Lounger
    Join Date
    Dec 2004
    Location
    Stoney Creek, Ontario
    Posts
    196
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Error 400 (2003)

    My very simple SendMail array macro is suddenly getting this error. I did add some email addresses to the array recently but when I debug, all is fine. The error message pops up as soon as I hit "yes" to allow a program to send this. What should I be looking at to fix this? (and the help button on the error 400 dialogue box brings up a blank page - very helpful).

    TIA.
    Deb

  2. #2
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Error 400 (2003)

    According to the help subject "Trappable errors", error number 400 means "Form already displayed; can't show modally". Do you use a userform?

  3. #3
    2 Star Lounger
    Join Date
    Dec 2004
    Location
    Stoney Creek, Ontario
    Posts
    196
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Error 400 (2003)

    Thanks Hans...well this is strange. No, I don't use a userform. It's just a spreadsheet that I email to people every week and the only thing that changes on the spreadsheet is the numbers. As I said, I did add some names in the array but I can't see that being the problem. Maybe when I go into work tomorrow, the computer genie will have mysteriously fixed this

  4. #4
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Error 400 (2003)

    In that case, Outlook might be trying to display the dialog that asks for permission again (erroneously). It might well be that the problem disappears after restarting.

  5. #5
    2 Star Lounger
    Join Date
    Dec 2004
    Location
    Stoney Creek, Ontario
    Posts
    196
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Error 400 (2003)

    I'll restart my system tomorrow and post back with the results...I have a feeling that you are right about this one. Thanks!

  6. #6
    2 Star Lounger
    Join Date
    Dec 2004
    Location
    Stoney Creek, Ontario
    Posts
    196
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Error 400 (2003)

    Hi Hans - restarting my system didn't make the problem go away. As I'm not that well-versed in code, is there something in the following that is creating this error?

    Sub Mail_384_Report()
    ActiveWorkbook.SendMail Array("address", "address", _
    "address", "adress", _
    "address", "address", _
    "address", "address", _
    "address", "address", _
    "address", "address", _
    "address", "address")

    End Sub

  7. #7
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Error 400 (2003)

    You mentioned that you added some addresses recently. Does the problem go away if you remove some addresses from the list? If so, it might be that the system tries to process more e-mails than it can handle. You could work around this by calling SendMail twice, each time with about half the recipients.

  8. #8
    2 Star Lounger
    Join Date
    Dec 2004
    Location
    Stoney Creek, Ontario
    Posts
    196
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Error 400 (2003)

    Good suggestion and I just tried that - it still results in this error. Very strange as I have another similar workbook that I send out weekly and it has roughly the same amount of recipients...it works fine. However, I guess I'll just make a distribution list in Outlook to resolve this one and get rid of the macro. Thanks again for your suggestions.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •