Results 1 to 7 of 7
  1. #1
    Star Lounger
    Join Date
    Feb 2001
    Location
    Tampa, Florida, USA
    Posts
    68
    Thanks
    0
    Thanked 0 Times in 0 Posts

    "Couldn't save; currently locked by user 'Admin'" (97 SR 1)

    Users are getting the following messages: "Couldn't save; currently locked by user 'Admin' on machine 'WHATEVER NAME'"; followed by "The Save operation failed;" followed by "Out of memory." This occurs when entering data in a form. We have option "no locks" selected. We compact weekly. I scrolled through the tables and found no"bad" records (with #error or #name in the cell). We have no extra .ldb files lying around.

    The database does contain linked tables, if that makes a difference. Also, in my recent reading, I see that running Repair without first being prompted is a definite no-no, and we have been doing that at the same time as our weekly compacts. Could this be the cause of our problems?

    Thank you for any suggestions or recommendations!

  2. #2
    4 Star Lounger
    Join Date
    Dec 2000
    Location
    London, Ontario, Canada
    Posts
    437
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: "Couldn't save; currently locked by user 'Admin'" (97 SR 1)

    I would suggest you insure all users exit the database and then run Jetcomp.exe, if you don't already have it, you can download it <A target="_blank" HREF=http://support.microsoft.com/support/kb/articles/Q273/9/56.ASP>Here</A>

  3. #3
    Star Lounger
    Join Date
    Feb 2001
    Location
    Tampa, Florida, USA
    Posts
    68
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: "Couldn't save; currently locked by user 'Admin'" (97 SR 1)

    Hi Brian -- If I download jetcomp.exe, I will have to upgrade to SR-2 first. Would I have to upgrade all the database users to SR-2?
    Thanks for your help,
    Erica

  4. #4
    4 Star Lounger
    Join Date
    Dec 2000
    Location
    London, Ontario, Canada
    Posts
    437
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: "Couldn't save; currently locked by user 'Admin'" (97 SR 1)

    <hr>I will have to upgrade to SR-2 <hr>
    I wasn't aware of that, did it tell you that in the readme file? I would think if you have SR2, you should apply it to all users regardless. I don't think it should affect the other users but, frankly, I don't know. I've had SR-2 since it was first available.

  5. #5
    Star Lounger
    Join Date
    Feb 2001
    Location
    Tampa, Florida, USA
    Posts
    68
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: "Couldn't save; currently locked by user 'Admin'" (97 SR 1)

    KB article Q172733 (which talks about downloading updated version of Jet 3.5 in order to obtain jetcomp.exe) says: To apply this service pack successfully, you need to have Microsoft Jet version 3.51.0623 or later installed on your computer. If your computer has an earlier version of Jet than this, you must upgrade your computer to Microsoft Office 97 Service Release 2."

    Erica

  6. #6
    Lounger
    Join Date
    Jun 2001
    Location
    Syracuse, NY
    Posts
    41
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: "Couldn't save; currently locked by user 'Admin'" (97 SR 1)

    First, you should update to SR2 anyway just because of bug fixes. But if you want to avoid that I think you can because you probably won't need to run JETCOMP as long as the regular one works.

    Instead do this:

    1. Create a fresh MDB container and import everything into it. This will (in most cases) eliminate any database corruption.

    2. Before opening, delete any .LDB files in that database directory. Typically, when someone disconnects abnormally, you'll end up with an entry in the .LDB file giving you a phantom user. Deleting it will clear this up.

    3. Check the client PC's were this is happening. Ensure that the TEMP and TMP environment variables point to a valid drive/directory and it has plenty of free disk space. This addresses the "out of memory" error, which may be the main cause of your problem.

    4. If the MDB is on a Novell Server, you may need to adjust the locks up or use the dbEngines SetOption method to set the max locks that JET can use below the setting in Novell. "Out of memory" occurs for a number of reasons other then being out of memory. This is one of them.

    HTH,
    Jim.

  7. #7
    Star Lounger
    Join Date
    Feb 2001
    Location
    Tampa, Florida, USA
    Posts
    68
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: "Couldn't save; currently locked by user 'Admin'" (97 SR 1)

    I'll give your suggestions a try before running Jetcomp. Thank you very much for your input,

    Erica

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •