Results 1 to 7 of 7
  1. #1
    Super Moderator
    Join Date
    Jun 2002
    Location
    Mt Macedon, Victoria, Australia
    Posts
    3,993
    Thanks
    1
    Thanked 45 Times in 44 Posts

    Virtual Directories IIS7 on Vista Business

    I have turned on IIS on my new Vista machine.

    If I go to http://localhost it works OK.

    But if I create Virtual Directory I get the following error. I have looked in the Basic and Advanced Settings and can't see anything that fixes it.
    The Physical Path Credentials are set to: Application User (Path Through Authentication).

    I have done this lots of times on myXP Pro machine without any problem, but I have no idea where to start here.
    Regards
    John



  2. #2
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,577
    Thanks
    5
    Thanked 1,057 Times in 926 Posts

    Re: Virtual Directories IIS7 on Vista Business

    See if this thread Carspace demo error - MSDN Forums helps. Also, have a look at IIS.net : IIS 7 : Microsoft Internet Information Services for much more information on configuration & security.

    Joe
    Joe

  3. #3
    Super Moderator
    Join Date
    Jun 2002
    Location
    Mt Macedon, Victoria, Australia
    Posts
    3,993
    Thanks
    1
    Thanked 45 Times in 44 Posts

    Re: Virtual Directories IIS7 on Vista Business

    Thanks for the response.

    The Carspace Demo article looks like it is describing the same problem, but I don't understand what it is telling me to do fix it.

    From the two articles, I thought I was being told to use Windows Explorer to give the IUSR account permission to read the folder set up as the virtual directory. But that did not fix it.
    Regards
    John



  4. #4
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,577
    Thanks
    5
    Thanked 1,057 Times in 926 Posts

    Re: Virtual Directories IIS7 on Vista Business

    Just glancing at the Carspace demo error - MSDN Forums thread again it says you need to add the IIS_IUSRS account to the USERS group. Then make sure it has READ&Execute, Listfoldercontents, and Read permissions. Is that what you did?

    Joe
    Joe

  5. #5
    Super Moderator
    Join Date
    Jun 2002
    Location
    Mt Macedon, Victoria, Australia
    Posts
    3,993
    Thanks
    1
    Thanked 45 Times in 44 Posts

    Re: Virtual Directories IIS7 on Vista Business

    A further bit of info following more testing.

    If the Physical Path to the Virtual Directory is just c:test the Virtual Directory works OK.

    But once the Physical Path is inside C:UsersJohnDocuments it does not work.
    Regards
    John



  6. #6
    Super Moderator
    Join Date
    Jun 2002
    Location
    Mt Macedon, Victoria, Australia
    Posts
    3,993
    Thanks
    1
    Thanked 45 Times in 44 Posts

    Re: Virtual Directories IIS7 on Vista Business

    That is what I did not know how to do, but I have just found out.

    But it was the IUSR account that needed to be added to the USERS group. Doing that was enough to fix my problem.

    Thanks for your trouble.
    Regards
    John



  7. #7
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,577
    Thanks
    5
    Thanked 1,057 Times in 926 Posts

    Re: Virtual Directories IIS7 on Vista Business

    No troulbe at all. Way to go!!! <img src=/S/clapping.gif border=0 alt=clapping width=19 height=23> Glad you've got it working. <img src=/S/grin.gif border=0 alt=grin width=15 height=15>

    Joe
    Joe

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •