Results 1 to 5 of 5
  1. #1
    2 Star Lounger
    Join Date
    Nov 2002
    Location
    Florida
    Posts
    124
    Thanks
    77
    Thanked 0 Times in 0 Posts

    Run As Command (XPSP2)

    Howdy all. Got a question that's bugging me to death. I have already enabled the run as command. It works fine on everything - EXCEPT - the control panel. Can anyone give me any ideas? I've tried everything that I can come up with to make it work on control panel, with no luck. Thanks in advance.

    Mike.

  2. #2
    Plutonium Lounger
    Join Date
    Oct 2001
    Location
    Lexington, Kentucky, USA
    Posts
    12,107
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Run As Command (XPSP2)

    Hello Mike. I laid in the grass for a bit to see if someone could help you, since I have no experience with the Run As feature. Do you mind a bit more info on why you are trying to do this, rather than being logged on with administrator privileges? When you try to "Run As" on the Control Panel, are you shift-right-clicking on the Control.Exe file in the System32 directory? Since I've never used the command, I have no idea whether it is "sticky" or if you have to use it each time you want to execute a file with different credentials. I did see the following in the XP Help files:
    <hr>If you try to start a program, such as an MMC console or Control Panel item, from a network location using Run as, it could fail if the credentials used to connect to the network share are different from the credentials used to start the program. The credentials used to run the program might not be able to gain access to the same network share.

    If Run as fails, the Secondary Logon service may not be running. For more information, click Related Topics.

    You can also use Run as from the command prompt. For more information, click Related Topics.

    The Secondary Logon service accepts only password authentication. If policies require smart card logon, then Run as will not work.<hr>
    The bolding is mine. I saw this text in Help by simply searching for "Run As".

  3. #3
    2 Star Lounger
    Join Date
    Nov 2002
    Location
    Florida
    Posts
    124
    Thanks
    77
    Thanked 0 Times in 0 Posts

    Re: Run As Command (XPSP2)

    Thanks Big Al. I'll check the secondary log on. I believe that was one of the things that I checked, but I'll make sure. The main reason I want to use the feature is because I always run everything from the limited account, instead of the admin account. I had it setup before I did a reformat, but since then, I can't get it to work again. I'm baffled, since run as works on everything else, it just refuses to work with control panel. It won't work, no matter from what point I try to run it - whether from System32, or a shortcut. I'll see what I come up with. Thanks again.

    Mike.

  4. #4
    Plutonium Lounger Leif's Avatar
    Join Date
    Dec 2000
    Location
    U.K.
    Posts
    14,010
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Run As Command (XPSP2)

    Just as a matter of interest, does the (same) shortcut work when you are logged in as administrator?

  5. #5
    2 Star Lounger
    Join Date
    Nov 2002
    Location
    Florida
    Posts
    124
    Thanks
    77
    Thanked 0 Times in 0 Posts

    Re: Run As Command (XPSP2)

    I was correct - the secondary log on is already active.

    Leif - I also tried the shortcut as admin, with the same result. It works fine when I double click it, too. My reason for all this, is that I occasionally like to run control panel items from the limited account, with admin privileges. Thanks again.

    Mike.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •