Results 1 to 9 of 9
  1. #1
    Silver Lounger
    Join Date
    Oct 2002
    Posts
    1,993
    Thanks
    0
    Thanked 0 Times in 0 Posts

    External links don't open in a new tab (Fx 2.0.0.5

    For some reason, when I click on a link to an external site, here in the Lounge, the page opens in the same tab in my Fx browser.

    I know about the setting; New pages will open in a new window or new tab (sorry, have to translate, don't know the exact wording in English Fx). It has always been set to new tab.

    I know about clicking with "middle-button", or ctrl-clicking. But it has always worked before in the Lounge, without doing so.

    Thought it maybe had something to do with the latest (more or less latest) version of the extension NoScript, but doesn't seem so.

    So is this a change in the Lounge or something else. And my knowledge about what the web developers do behind the scene is zero, so at other sites it may work or not work that way. (But of course one can always force it to open with ctrl-click etc.).

    Any thoughts?

  2. #2
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: External links don't open in a new tab (Fx 2.0.0.5

    Nothing has been changed in the Lounge scripts recently.

    I just tested in FireFox 2.0.0.5 (with NoScript 1.1.6.03) - external links still open in a new tab.

  3. #3
    Plutonium Lounger
    Join Date
    Oct 2001
    Location
    Lexington, Kentucky, USA
    Posts
    12,107
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: External links don't open in a new tab (Fx 2.0

    Me too, Argus - what Hans found, that is. I don't have ANY extensions running and I do have 2.0.0.5 installed. I always get a new tab when I click an external link and have all day today. It looks like one of your Fx settings may have accidently gotten modified. I don't know where else to suggest you look, since you've already confirmed the "...new tab..." setting.

  4. #4
    Silver Lounger
    Join Date
    Oct 2002
    Posts
    1,993
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: External links don't open in a new tab (Fx 2.0

    Thank you Hans!

    <img src=/w3timages/censored.gif alt=censored border=0>, I knew it! Have to see if there is some Fx/Fx config-aficionado, that can help troubleshoot.

    At the moment I'm running Fx 2.0.0.5 and NoScript 1.1.6.07. I know, I know, there is a later NoScript. It's updated often. But I've had some odd, small problem with that update process (or more correct the extension update process when run automatically at Fx start time, not when running search for updates).

    After a complete, clean install of Fx 2.0.0.4 some weeks ago (after a little cleaning), I installed whatever NoScript ver. was around. Then, as we know, Fx can search for updates (have had no problem with this before), either when running or it can happen when you start Fx it tells that there is a new version of Fx, or in my case an extension.

    After the first install mentioned, I got such a prompt some days later at Fx start, chose to install the updated extension, but version number didn't correspond (i.e. correct ver. nr. at icon down right, but the old ver. nr. in Tools > Extensions). Selected search in Extension dialog and downloaded/installed again, restarted Fx, and it worked, showed correct version.

    Then this happened once again some days ago, seems like the dowload/install at start of Fx has some problems. I.e. I got a non-corresponding version info. Even if I closed Fx and reopened. OTOH this was "introduced" sometime around NoScript 1.1.6.X, didn't see it at 1.1.5 or before.

    Also this "download at start" seems to bring back "last session", i.e. closed tabs under History, odd since Fx normally purges that when closing. This time I uninstalled NoScript, restarted Fx and went to addons.mozilla.org, and did a "clean" download/install of ver. 1.1.6.07.

    BTW, I am normally not so much into this extension thing, but thanks to a tip from <!profile=jscher2000>jscher2000<!/profile>, I'm a happy user of NoScript.

  5. #5
    Silver Lounger
    Join Date
    Oct 2002
    Posts
    1,993
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: External links don't open in a new tab (Fx 2.0

    Hi Al,
    Thanks, even if it's bad news for me. <img src=/S/grin.gif border=0 alt=grin width=15 height=15>

    Actually what I did check before was; Tools > Settings > Tabs, and confirmed that the setting was indeed "new tab", then selected OK. That is, I didn't try to change it, then change back, only confirmed with an OK click.

    Just tested, it doesn't work, my normal luck. If I change the setting to "new window", that works OK, it opens the link in a new window. But if I change it back to "new tab", it doesn't work, it will open the link in the present tab.

    Arrrggggh, the Lounge is so slow at the moment. <img src=/S/sad.gif border=0 alt=sad width=15 height=15> Oh, look a hole in space-time, it's working again, let's post.

  6. #6
    4 Star Lounger
    Join Date
    Jan 2001
    Location
    Dundee, Scotland
    Posts
    404
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: External links don't open in a new tab (Fx 2.0

    Argus and Al,

    I know this is off-topic a bit, but if you are running firefox extension-less, why not consider switching to Opera? The latest version 9.22 has been extremely stable for me, and out of the box (wire?) handles pop-ups (what are they?) and contains a fairly easy to use content-blocker. I never see those irritating flashing adverts (more than once...) that horrify me so much when I am forced to use IE. Just my <img src=/S/2cents.gif border=0 alt=2cents width=15 height=15>
    John (Unreconstructed Jacobite)

  7. #7
    Silver Lounger
    Join Date
    Oct 2002
    Posts
    1,993
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: External links don't open in a new tab (Fx 2.0

    It works! It works! Where is that ultra-happy smiley? <img src=/S/smile.gif border=0 alt=smile width=15 height=15>

    After doing some other business on the net this morning I went to do a post in the Lounge, then I found I could not bring up the TagPanel in the "Make a New Post"-page. What! Yep, JavaScript. We are not amused! Since I knew NoScript 1.1.6.08 was out, I logged out, closed Fx, restarted Fx and did a scan for extensions (1.1.6.08 was already there as a new update, but did a scan anyway), downloaded/installed NoScript1.1.6.08, just to be told by the author that 1.1.6.11 is out. No thank you, not yet. Restarted Fx again and went to the Lounge, now the links work in my post, and also Oscar [the cat]. <img src=/S/smile.gif border=0 alt=smile width=15 height=15>

    Shall we blame NoScript? Well, a lot better than blaming the Lounge or me. <img src=/S/grin.gif border=0 alt=grin width=15 height=15>
    <img src=/S/groovin.gif border=0 alt=groovin width=21 height=21>

  8. #8
    Silver Lounger
    Join Date
    Oct 2002
    Posts
    1,993
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: External links don't open in a new tab (Fx 2.0

    Hi,
    I know about Opera, even tried it years ago (on a Win9x PC), and I know they have a fine mini-browser for mobile phones. Thanks for your tip. I am pleased with Fx. Right out of the box it works great, no pop-ups, it's simple to deny pictures from certain sites, if one like etc. And if one don't install Flash it is a very nice and quiet ride.

    What I would like to control is the use of JavaScript, in plain Fx there is an all or nothing approach when it comes to different sites, though one can restrict it somewhat, what JavaScript can do. That is why I use the NoScript extension. With it I can also have Flash installed, but still block even that on untrusted sites etc.

    Compared to IE, well I have not used IE7 so much, but when it comes to IE the big difference, for me, was before and after IE6 SP2. Before pop-ups etc. was a pain.

  9. #9
    4 Star Lounger
    Join Date
    Jan 2001
    Location
    Dundee, Scotland
    Posts
    404
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: External links don't open in a new tab (Fx 2.0

    I know that everyone has their own browser preferences, and I have Firefox installed with adblock plus for my grandson's use. If you haven't seen opera since win9x days, I recommend a quick glance. There are tons of new features, and I still think it's got a faster rendering engine than Fx. Like you I haven't considered using IE7 and only fire up ie6 on the odd occasion that badly coded sites deny (or just plain don't work) in Opera or FX, but thanks for your feedback.
    John (Unreconstructed Jacobite)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •