Results 1 to 6 of 6
  1. #1
    2 Star Lounger
    Join Date
    Mar 2002
    Location
    Waltham, MA, USA
    Posts
    160
    Thanks
    0
    Thanked 2 Times in 2 Posts

    Access denied to my own files (2002, Service Pack

    I pulled the hard drive from a laptop computer that died, installed the drive in a USB enclosure and attempted to read the files using another computer. I can access all files except those in the My Documents folder. I can view the contents of the My Documents folder using Windows Explorer, but when I try to open or copy a file, I am informed "access denied" even though I have the same username and password on the new computer.

    Thanks a lot, Microsoft, for protecting me from hijacking my own files. Now, how can I retrieve these files? Install the drive as the C: drive in a different computer (and would Safe Mode work OK if the other computer isn't the same kind?) Use Linux/ Use a backup utility or other software? Through some magic command sequence I don't know about? What?

  2. #2
    Plutonium Lounger
    Join Date
    Nov 2001
    Posts
    10,550
    Thanks
    0
    Thanked 7 Times in 7 Posts

    Re: Access denied to my own files (2002, Service Pack

    Windows identifies the owner of a file using a unique id. The username and password on your new computer will have a different ID to the ones on your old computer, so you are no longer the owner of these files.

    These instructions for seizing the ownership of files are correct for Windows XP Pro, there may be differences on Windows XP Home.
    <UL><LI>Log in as an account that has Administrator access
    <LI>Right click the folder in Windows Explorer
    <LI>Choose properties from the menu
    <LI>Select the security tab
    <LI>Click the Advanced button
    <LI>Click the Owner tab
    <LI>Select your username
    <LI>Select the checkbox that says to replace owner on subcontainers and objects
    <LI>Click OK[/list]StuartR

  3. #3
    2 Star Lounger
    Join Date
    Mar 2002
    Location
    Waltham, MA, USA
    Posts
    160
    Thanks
    0
    Thanked 2 Times in 2 Posts

    Re: Access denied to my own files (2002, Service P

    Thanks -- but I have XP Media Edition version 2002 Service Pack 2. The options in the Properties dialog are different. There is a Sharing tab, not a Sharing and Security tab. The dialog tells me that that I can drag the folder to the Shared Documents folder to share files, but access is denied to drag it to that folder either on the same drive or on the C: drive.

    This is vexing. This is the kind of discord between what is offered and what actually works that makes people hate Windows.

    The dialog box also has a checkbox to share the files "on the network and with other uses of this computer", and I have that option set, but Windows apparently still thinks "this computer" is the old one, and I don't have a network here on vacation to try copying to another computer.

    What if I renamed the present computer same as the old one? Will that change the unique ID to the right one?

    Just to show that I'm not all negative, I'll say a nice thing now -- about Woody's Lounge. It responds quickly here on dial-up where I am on vacation :-) -- nice smooth display but no graphics fluff to extend download time. Well, except that little lizard who pops up, but he's fun!

  4. #4
    Plutonium Lounger
    Join Date
    Nov 2001
    Posts
    10,550
    Thanks
    0
    Thanked 7 Times in 7 Posts

    Re: Access denied to my own files (2002, Service P

    I don't know Windows XP Media Centre edition, but if it behaves like XP Home you will have to start your computer in Safe Mode to get the security tab.

    StuartR

  5. #5
    Uranium Lounger
    Join Date
    Dec 2000
    Location
    Salt Lake City, Utah, USA
    Posts
    9,508
    Thanks
    0
    Thanked 6 Times in 6 Posts

    Re: Access denied to my own files (2002, Service P

    XP MCE is a "flavor" of XP Pro. In my XP MCE installation, to show the Security tab, the user needs to CLEAR the checkbox under Control Panel | Folder Options | View | Advanced settings listbox | Use Simple File Sharing, and restart the computer. (The user may also need Admin privileges - I didn't test this setting without them.)

    You are correct that booted in Safe Mode the Security Owner tab is available under folder Properties.
    -John ... I float in liquid gardens
    UTC -7ąDS

  6. #6
    2 Star Lounger
    Join Date
    Mar 2002
    Location
    Waltham, MA, USA
    Posts
    160
    Thanks
    0
    Thanked 2 Times in 2 Posts

    Re: Access denied to my own files (2002, Service P

    FYI I found one answer to my problem that worked for me -- and was very convenient. I also have been told of a couple of other possibilities.

    What worked for me was simply to back up the folder to a Maxtor One-Touch drive. The One-Touch software removes the lock on the files. Makes sense, doesn't it -- otherwise, they would not be usable when the original hard drive fails, and Maxtor would be inundated in support calls.

    Another suggestion was that the sharing and security tab for the folder lets you change the ownership of the files. But I also found that option unavailable in Windows Home Edition or Media edition. Later, I was told that it might be available in Safe Mode. But then I don't know whether USB drives are accessible in Safe Mode.

    A third suggestion was to try Linux, or an earlier version of Windows. the only earlier version of Windows I have on another computer here is Windows 98 SE, which doesn't support NTFS.

    I didn't try either of these options, having solved my problem.

    BTW be careful of the ins and outs of the Maxtor drive (avoid switching drives with the same drive letters, One-touch can't tell them apart; and it only keeps five copies so you need a separate long-term archive). Given these limitations, it is very convenient.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •