Results 1 to 8 of 8
  1. #1
    New Lounger
    Join Date
    Dec 2002
    Location
    Brisbane, Queensland, Australia
    Posts
    18
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Application.Printers Spoolsv.exe 100% (2003/3)

    Though testing the new service pack, we've discovered a problem with the Service Pack 3 of Access 2003 on Windows XP Service Pack 2.

    If you run the code below, it will hang with the program Spoolsv.exe running at 100% on the line with "Application.Printers":

    We've also found that it doesn't create clean compiled .mde's. Has anyone else had similar problems?

    Sub asas()
    On Error GoTo Err_Form_Open

    Dim Prt As Printer
    Dim sDefault As String

    sDefault = Application.Printer.DeviceName
    MsgBox Application.Printers.Count
    For Each Prt In Application.Printers
    Next Prt

    Exit_Form_Open:
    Set Prt = Nothing
    Exit Sub

    Err_Form_Open:
    MsgBox Err.Description, vbCritical + vbDefaultButton1 + vbOKOnly, "Form - Sub Form_Open"
    Resume Exit_Form_Open

    End Sub

  2. #2
    New Lounger
    Join Date
    Dec 2002
    Location
    Brisbane, Queensland, Australia
    Posts
    18
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Application.Printers Spoolsv.exe 100% (2003/3)

    One thing also that I would like to add is that our only difference from the standard office setup is that we have had to install the SQL Server 2005 GUID bug hotfix "WindowsXP-KB895751-v2-x86-ENU.exe".

    We don't think that is the problem as this problem doesn't appear on Windows 2000 SP4 machines that have the hotfix applied to them.

  3. #3
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Application.Printers Spoolsv.exe 100% (2003/3)

    I cannot find any mention of this problem. That doesn't mean it doesn't exist, but apparently it's not widespread

  4. #4
    Platinum Lounger
    Join Date
    Dec 2001
    Location
    Melbourne, Australia
    Posts
    4,594
    Thanks
    0
    Thanked 27 Times in 27 Posts

    Re: Application.Printers Spoolsv.exe 100% (2003/3)

    SP3 also screws up combo boxes

  5. #5
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Application.Printers Spoolsv.exe 100% (2003/3)

    I have tried it on a PC with Access 2003 SP3 installed, but Application.Printers didn't cause a problem.
    (SQL2005 was not installed on this PC)

  6. #6
    New Lounger
    Join Date
    Dec 2002
    Location
    Brisbane, Queensland, Australia
    Posts
    18
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Application.Printers Spoolsv.exe 100% (2003/3)

    Hi Hans,

    I've narrowed it down to one of our printer drivers. Not sure which one yet, but when I removed them all but the Office 2003 ones "Microsoft Office Document Image Writer" and "Microsoft XPS Document Writer" it works fine again.

  7. #7
    New Lounger
    Join Date
    Dec 2002
    Location
    Brisbane, Queensland, Australia
    Posts
    18
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Application.Printers Spoolsv.exe 100% (2003/3)

    Well a printer driver must have got corrupt. We've now reinstalled them all and it's working fine.

    The only other interesting thing was that the last test I did after removing the third printer driver causes Windows XP SP2 to Blue Screen and killed the Novell Client. So after I re-installed the Novell Client and removed the printer drivers the issue hasn't shown it's face again.

  8. #8
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Application.Printers Spoolsv.exe 100% (2003/3)

    I'm glad you were able to solve this. I wouldn't have guessed that that was the cause.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •