Results 1 to 9 of 9
  1. #1
    5 Star Lounger
    Join Date
    May 2001
    Location
    Allen, Texas, USA
    Posts
    661
    Thanks
    1
    Thanked 0 Times in 0 Posts

    video driver issue with Direct 3D Acceleration (XP Pro SP2)

    My sons computer is getting a direct 3D Acceleration failure when running the Direct X Diagnostic Tool.
    He has a NVIDIA Riva TNT2 Model 64/Model 64 Pro driver file version 6.14.10.5673. I just upgraded it to 6.14.10.7184, but it didn't fix that problem. When I tried installing the latest drivers, it says that it didn't find anything compatible to upgrade.

    There are many of his games that do not work because of the 3D not working.
    Is this a sign of a bad video card or do I need to upgrade to the correct driver?
    Some time ago I had this same problem and I thought upgraded the driver and it worked; but later had to reformat the drive and we are back to the same problem. If it's a driver issue, how do I go about finding the correct driver?

    Thanks for your help!
    --KZ

  2. #2
    Uranium Lounger viking33's Avatar
    Join Date
    Jun 2002
    Location
    Cape Cod, Massachusetts, USA
    Posts
    6,308
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: video driver issue with Direct 3D Acceleration (XP Pro SP2)

    KZ,
    NVIDIA cards use ( or at least they did use ) a universal driver update, so that V 7184 would replace all other lower numbered versions for all cards, as you have done.

    I would try to uninstall whatever version you now have and reboot, letting the system install the default VGA
    ( terrible ) version and refusing to let the system install anything else when it says it found new hardware. Then manually install the latest version you have. ( 7184 )
    BOB
    http://lounge.windowssecrets.com/S/flags/USA.gif http://lounge.windowssecrets.com/S/f...sachusetts.gif


    Long ago, there was a time when men cursed and beat on the ground with sticks. It was called witchcraft.
    Today it is called golf!

  3. #3
    5 Star Lounger
    Join Date
    May 2001
    Location
    Allen, Texas, USA
    Posts
    661
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Re: video driver issue with Direct 3D Acceleration (XP Pro SP2)

    Thanks. I'll try that this weekend. So, you think it's just a driver issue?

    --Ken

  4. #4
    Uranium Lounger viking33's Avatar
    Join Date
    Jun 2002
    Location
    Cape Cod, Massachusetts, USA
    Posts
    6,308
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: video driver issue with Direct 3D Acceleration (XP Pro SP2)

    It SOUNDS that way.
    Just make sure you UNinstall the old version as described above. <img src=/S/crossfingers.gif border=0 alt=crossfingers width=17 height=16>
    BOB
    http://lounge.windowssecrets.com/S/flags/USA.gif http://lounge.windowssecrets.com/S/f...sachusetts.gif


    Long ago, there was a time when men cursed and beat on the ground with sticks. It was called witchcraft.
    Today it is called golf!

  5. #5
    5 Star Lounger
    Join Date
    May 2001
    Location
    Allen, Texas, USA
    Posts
    661
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Re: video driver issue with Direct 3D Acceleration (XP Pro SP2)

    Well...I did as you suggested. After rebooting, it went into VGA mode. I then installed the newer driver and rebooted. I then ran the 3D test and it said:
    "Test failed at step 8 (creating 3D device): HRESULT-0x887602eb (error code).

    Now what?
    There are newer drivers than the one I installed, but when I tried to install before it would tell me that it didn't find anything compatible to install. Do I need to uninstall this version again and go direct to a newer version perhaps?

    --KZ

  6. #6
    Uranium Lounger viking33's Avatar
    Join Date
    Jun 2002
    Location
    Cape Cod, Massachusetts, USA
    Posts
    6,308
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: video driver issue with Direct 3D Acceleration (XP Pro SP2)

    I googled that error message and it seems like ALL of the hits suggest that it's a software problem.
    They also suggest the uninstallation of the current drivers by way of Device Manager and rebooting into VGA, then reinstalling as I said.
    None that I read, mentioned a hardware problem although I suppose it's always a possibility but not a strong one.

    I would try again and make SURE all remnants of the old drivers are gone. Go into Windows Explorer and look for any mention of the video card and delete them.
    Reboot and get the latest drivers from NVIDIA to install.

    If you google that error message, you will see that it seems to be common with the NVIDIA adapter.

    Striking out with all of the above, I would try to talk with a NVIDIA tech to see what they would suggest.
    BOB
    http://lounge.windowssecrets.com/S/flags/USA.gif http://lounge.windowssecrets.com/S/f...sachusetts.gif


    Long ago, there was a time when men cursed and beat on the ground with sticks. It was called witchcraft.
    Today it is called golf!

  7. #7
    5 Star Lounger
    Join Date
    May 2001
    Location
    Allen, Texas, USA
    Posts
    661
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Re: video driver issue with Direct 3D Acceleration (XP Pro SP2)

    Did it again and even deleted a lot of entries in the registry too.
    While in VGA mode in looking at the device manager it still listed that driver as X'd out, so I uninstalled it there too, then tried to install the NVIDIA, but it didn't install because there was nothing compatible. Had to reboot again for it to even install the newer driver. No luck...same as before. [img]/forums/images/smilies/sad.gif[/img]

    Guess I'll try tech support at NVIDIA.

    For what it's worth, in the Device manager there are two unknown devices that won't install: Other PCI Bridge Device and SM Bus Controller".
    Could that be part of the problem?

    --KZ

  8. #8
    5 Star Lounger
    Join Date
    May 2001
    Location
    Allen, Texas, USA
    Posts
    661
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Re: video driver issue with Direct 3D Acceleration (XP Pro SP2)

    The NVIDIA support wasn't much help. [img]/forums/images/smilies/sad.gif[/img]

    Trying to at least get rid of those two unknown device errors. I have Nforce 3-A v 1.0B (says v1.0A on the board, but B on start up).
    Each of the download areas for NFORCE3-A(1.0A) Bios v 1.0b bring up the download for f. Is it OK to download the f version or do I need to locate the b?



    --KZ

  9. #9
    5 Star Lounger
    Join Date
    May 2001
    Location
    Allen, Texas, USA
    Posts
    661
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Re: video driver issue with Direct 3D Acceleration (XP Pro SP2)

    (Edited by HansV to make URL clickable - see <!help=19>Help 19<!/help>)

    I found the b version here:
    http://www.softwaredriverdownload.com/down...ce3_driver.html

    It installed fine and even took care of those two unknown device issues....was hoping it would correct the video problem too, but it didn't.
    Should I use a newer version like "f"???

    --KZ

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •