Results 1 to 6 of 6
  1. #1
    4 Star Lounger
    Join Date
    Feb 2001
    Location
    BECCLES, Suffolk, England
    Posts
    407
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Data missing from list box (WXpHeSp2 Off2003)

    We have our access database on pc1 and when I open it on pc2 the data in the list boxes does not show! For instance on pc1 the client status list box displays the values: Active Ceased Inactive; these are not displayed when I click on the drop down list box on pc2. Anyone help or explain please?
    <IMG SRC=http://www.wopr.com/w3tuserpics/StephenElms_sig.jpg> Didn't think that I made my first post here on 5th February 2001...!

  2. #2
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Data missing from list box (WXpHeSp2 Off2003)

    Check whether there are missing references on PC2:
    - Open the database on PC2 (with the Shift key held down if you want to bypass startup options)
    - Press Alt+F11 to activate the Visual Basic Editor.
    - Select Tools | References...
    - Do you see any references whose check box is ticked (they're at the top of the list) and whose name starts with MISSING?
    - If so, clear their check boxes, then click OK.
    - Switch back to Access to see if the problem has been solved.

  3. #3
    Gold Lounger
    Join Date
    Jun 2001
    Location
    Crystal Beach, FL, Florida, USA
    Posts
    3,436
    Thanks
    1
    Thanked 34 Times in 34 Posts

    Re: Data missing from list box (WXpHeSp2 Off2003)

    Has pc2 been updated to Access2003 SP3? We've notice this type of behavior will often occur; at least with combo boxes, not sure whether we've seen it with listboxes.
    Mark Liquorman
    See my website for Tips & Downloads and for my Liquorman Utilities.

  4. #4
    4 Star Lounger
    Join Date
    Feb 2001
    Location
    BECCLES, Suffolk, England
    Posts
    407
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Data missing from list box (WXpHeSp2 Off2003)

    Hi Hans, thanks for that info'. No change - and nothing shows up as missing.
    <IMG SRC=http://www.wopr.com/w3tuserpics/StephenElms_sig.jpg> Didn't think that I made my first post here on 5th February 2001...!

  5. #5
    4 Star Lounger
    Join Date
    Feb 2001
    Location
    BECCLES, Suffolk, England
    Posts
    407
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Data missing from list box (WXpHeSp2 Off2003)

    Hi Mark,
    Yes our Acess is SP3....
    <IMG SRC=http://www.wopr.com/w3tuserpics/StephenElms_sig.jpg> Didn't think that I made my first post here on 5th February 2001...!

  6. #6
    Gold Lounger
    Join Date
    Jun 2001
    Location
    Crystal Beach, FL, Florida, USA
    Posts
    3,436
    Thanks
    1
    Thanked 34 Times in 34 Posts

    Re: Data missing from list box (WXpHeSp2 Off2003)

    This may or may not help, but I'd change the rowsource for the listbox so that you add a zero-length string to the field being displayed. For example, right now your rowsource may be this:

    SELECT ID, Description FROM mytable

    Change it to this:

    SELECT ID, Description & "" FROM mytable
    Mark Liquorman
    See my website for Tips & Downloads and for my Liquorman Utilities.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •