Results 1 to 3 of 3
  1. #1
    Star Lounger
    Join Date
    Apr 2003
    Location
    Morgantown, Pennsylvania, USA
    Posts
    94
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Date Format Switching (2000)

    Hello,

    I was asked this question and I can't reproduce the problem, so I'm asking the loungers.

    A person from the United States took their laptop to Canada. While in Canada, the person connected to their network over the Hotel internet service, and typed in dates in a column. The dates got changed from mm/dd/yyyy format to dd/mm/yyyy format. (I can duplicate this by choosing Format, Cells, and changing the date format location from English (United States) to English (Canadian)). This person has now returned to the United States. Now, when they open Excel connected to their network locally, not only does the date display in dd/mm/yyyy format as the default, but if they try to enter the date as mm/dd/yyyy they get an error. Excel seems to only allow them to enter dates in dd/mm/yyyy format now.

    I'm thinking that their Book template has changed, but I can't conform this, so my questions are:

    Where is the book template located?

    What can be done to change this back to US date format?

    Thanks,

  2. #2
    WS Lounge VIP sdckapr's Avatar
    Join Date
    Jul 2002
    Location
    Pittsburgh, Pennsylvania, USA
    Posts
    11,225
    Thanks
    14
    Thanked 342 Times in 335 Posts

    Re: Date Format Switching (2000)

    It sounds to me more like a windows control panel "regional settings" issue rather than an excel issue

    Has he/she checked the regional settings in Windows?

    Steve

  3. #3
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Date Format Switching (2000)

    From your description it appears as if the date format in the Date, Time, Language and Regional Options control panel has been changed to the Canadian setting. The format Excel uses by default is controlled by this Windows setting. If it was just an Excel setting, it would still be possible to enter dates in USA date format.
    I have no idea why the setting in the control panel would change (it's not changed automatically if you travel from one country to another), but my first suggestion would be to check the control panel.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •