Results 1 to 6 of 6
  1. #1
    Lounger
    Join Date
    Jan 2001
    Location
    Winnipeg, Manitoba, Canada
    Posts
    40
    Thanks
    0
    Thanked 0 Times in 0 Posts

    keyboard changes language by itself (Vista Home Premium)

    One more problem ...
    My new HP laptop running Vista Home Premium has an annoying habit of changing default languages so when I press shift + another key it gives my the French symbol not the English. Itès Ok after a reboot.
    Being from Canada, I would like to keep Canadian English as a default language - but I suspect that it is affecting the keyboard.
    Any hints É

    Thanks,
    Don

  2. #2
    Star Lounger
    Join Date
    Jan 2008
    Location
    Hooterville, North Carolina, USA
    Posts
    77
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: keyboard changes language by itself (Vista Hom

    Click on Start. Then on Help and Support.
    When the window for Help pops up, in the search box, type in 'change keyboard language' and hit Enter.
    Follow what is there.

  3. #3
    Lounger
    Join Date
    Jan 2001
    Location
    Winnipeg, Manitoba, Canada
    Posts
    40
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: keyboard changes language by itself (Vista Hom

    Hi Jimbo,
    I have looked at that and even followed the instructions at Regional and Language options / Keyboards and Languages / Change Keyboards / Default Input Language to change the default to US - but it seems to change by itself.
    I locked the Language bar to the Taskbar - so at least now it will be easier to change back next time it happens. I disabled the keystrokes for changing languages. Maybe I had a case of fat fingers hitting the magic keystroke sequence unknown to me. Who knows ?
    Thanks for the info.

    Don

  4. #4
    Gold Lounger Rebel's Avatar
    Join Date
    Jul 2001
    Location
    Canada
    Posts
    3,024
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: keyboard changes language by itself (Vista Hom

    Don,
    In the Installed Services on the General Tab of the Text Services and Input Languages (from Control Panel's Regional & Language Options), select (or add) the US Keyboard. If there is more than one keyboard in the list (such as Canadian French or Canadian Multilingual Standard), either promote the US keyboard to the top o the list or remove the Canadian Keyboards. Then in the Default input language section, Select English (Canada) - US as the combination language/keyboard. This will leave Canadian English and the US keyboard as default.
    John
    A Child's Mind, Once Stretched by Imagination...
    Never Regains Its Original Dimensions

  5. #5
    Lounger
    Join Date
    Jan 2001
    Location
    Winnipeg, Manitoba, Canada
    Posts
    40
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: keyboard changes language by itself (Vista Hom

    Hi John,
    That's the way that it was set up - but every so often the keyboard would change. i suspect that it was the Advanced Key Settings / Hot Keys for input langauges key sequence that was the problem. I changed the Hot Keys between input langauges to 'not assigned' and it hasn't happened again.
    Another Vista "feature" disabled.
    Thanks for answering.
    Don

  6. #6
    Gold Lounger Rebel's Avatar
    Join Date
    Jul 2001
    Location
    Canada
    Posts
    3,024
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: keyboard changes language by itself (Vista Hom

    Good to hear. Let's keep our <img src=/S/crossfingers.gif border=0 alt=crossfingers width=17 height=16> .
    John
    A Child's Mind, Once Stretched by Imagination...
    Never Regains Its Original Dimensions

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •