Results 1 to 6 of 6
  1. #1
    2 Star Lounger
    Join Date
    Apr 2002
    Location
    Evansville, Indiana, USA
    Posts
    132
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Forms in Vista vs XP (2007)

    One of the forms on my database is a time log. The users input the number of hours in a text box representing each day of the week. There is another text box that totals this time. When I run the form on a computer that has XP, the totals work fine. When I run the form on computers with Vista, the form does not total. It doesn't matter if I run the database in runtime or full access. Does anyone know what might be stopping the form from totaling?

  2. #2
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Forms in Vista vs XP (2007)

    Is the control source of the totals text box a formula starting with = or is it populated by VBA code?

  3. #3
    2 Star Lounger
    Join Date
    Apr 2002
    Location
    Evansville, Indiana, USA
    Posts
    132
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Forms in Vista vs XP (2007)

    It is a formula starting with an =.

  4. #4
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Forms in Vista vs XP (2007)

    Sadly, that means I have no idea what causes this, having neither Windows Vista nor Access 2007.

  5. #5
    Super Moderator
    Join Date
    Jun 2002
    Location
    Mt Macedon, Victoria, Australia
    Posts
    3,993
    Thanks
    1
    Thanked 45 Times in 44 Posts

    Re: Forms in Vista vs XP (2007)

    Is there much data involved?

    I have been told about a similar problem with one of my databases lately, but I can't reproduce the problem on my Vista/Access 2007 machine. Vista/Access 2007 seems to take longer to do everything, so I am wondering if it is just taking too long to calculate the total.
    Regards
    John



  6. #6
    2 Star Lounger
    Join Date
    Apr 2002
    Location
    Evansville, Indiana, USA
    Posts
    132
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Forms in Vista vs XP (2007)

    I wouldn't call it "much". I would say its average. I added a recalc to the onload event and now the totals show. It is a subform that is set to continuous. All records show the total, but the first record shows the total for about 2 seconds and then it shows and empty box. I am not sure what is going on here. This is only happening on vista machines.

    Thanks for all your help.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •