Results 1 to 6 of 6
  1. #1
    Star Lounger
    Join Date
    Jan 2001
    Posts
    69
    Thanks
    0
    Thanked 0 Times in 0 Posts

    PWS (IIS 5) Setup Problems on Windows2000 Pro

    Hi,

    I have problems with PWS (IIS 5) install on windows2000; I got it installed and it runs; Internet Explorer will display HTML webpages fine but gives error when attempting to display ASP webpages; example, when i type in http://localhost/default.htm, IE displays webpage; when i use default.asp I get a page cannot be displayed error; I am not familiar with PWS on windows 2000; do i need to do something for it to recognize ASP pages? I looked at permissions and they seem fine (read/ run scripts);

    Thanks you!

    --Llyal

  2. #2
    Uranium Lounger
    Join Date
    Jan 2001
    Location
    Cincinnati, Ohio, USA
    Posts
    7,089
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: PWS (IIS 5) Setup Problems on Windows2000 Pro

    Is it happening on all ASP pages? Or just the local ones? If it's local only, meaning you're running it from localhost, you might need to enable scripting in your pages - check your IE security settings.
    -Mark

  3. #3
    Star Lounger
    Join Date
    Jan 2001
    Posts
    69
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: PWS (IIS 5) Setup Problems on Windows2000 Pro

    Mark,

    I checked the security settings for intranet and they look good;

    Another observation, when i go to a local website location and do not explicitly put "default.htm", IE returns an error saying page cannot be displayed; I might have to setup a fresh machine and see if problems persists;

    --Llyal

  4. #4
    Uranium Lounger
    Join Date
    Jan 2001
    Location
    Cincinnati, Ohio, USA
    Posts
    7,089
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: PWS (IIS 5) Setup Problems on Windows2000 Pro

    i don't have IIS on the machine where I'm at, so I can't tell you specifically where to go - but if you open the IIS properties in the management console, and look at the properties of the root web, you should be able to specify a default document (default.htm, index.htm, default.asp, index.asp). I've had a few instances where you need to change the properties and re-apply them in order for IIS to get its act together.

    You could also try removing the IIS component, rebooting, and then installing it again. Or maybe go with Linux and Apache <g>.
    -Mark

  5. #5
    Star Lounger
    Join Date
    Jan 2001
    Posts
    69
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: PWS (IIS 5) Setup Problems on Windows2000 Pro

    Mark,

    Thanks for the suggestions;

    I did a test install of Windows2000 pro on another machine and find that the PWS (IIS) works fine without a hitch when installed; so my current setup is corrupted; the service packs and other tricks do not fix problem;

    I suggest to others that they install PWS (IIS) shortly after they install WIndows2000; I had decided to install PWS long after I configured the machine with other programs and I got problems;

    --Llyal

  6. #6
    3 Star Lounger
    Join Date
    Jan 2001
    Location
    Minneapolis, Minnesota, USA
    Posts
    336
    Thanks
    2
    Thanked 4 Times in 4 Posts

    Re: PWS (IIS 5) Setup Problems on Windows2000 Pro

    I wonder if this is related to a small oddity I have noticed on my system. I note that you are using the url http://localhost to view your page on IIS5. I find that, if I am testing a page with a java applet, the applet does not load if I use the "localhost" address, but it loads just fine if I use http://computername.

    Fafner

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •