Results 1 to 2 of 2
  1. #1
    qriusjorj
    Guest

    Undefined function 'Nz' in expression

    Hi, everyone!

    I have a database which is used on a LAN by up to 25 different stations.

    One user continually has problems where my code references the Nz function. No other user has this problem.

    The only difference on this machine is that it's running MS Windows ME. Everyone else is running W98.

    Anyone know of a ME/Access 2000 bug?

    Thanks!
    Sam

  2. #2
    2 Star Lounger
    Join Date
    Apr 2001
    Location
    Wellington, New Zealand
    Posts
    173
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Undefined function 'Nz' in expression

    Ages old post I know, but saw it and had a possible solution (should you not have already solved it).

    Sometimes, having MISSING references to a library can causes spurious results and funny error messages like this (I have experienced the same with the 'format' function. You may have a reference in the database, that all other users have the appropriate file for, but this user is missing it.

    If you go into the VBA window and select, tools --> references, you may see a MISSING next to one of the selected references (on the users machine that is having the problems).

    Like I said, I know this is old ... but interesting still the same [img]/forums/images/smilies/smile.gif[/img]

    Cheers

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •