Results 1 to 6 of 6
  1. #1
    Star Lounger
    Join Date
    Feb 2008
    Location
    philadelphia, Pennsylvania
    Posts
    72
    Thanks
    11
    Thanked 0 Times in 0 Posts

    Invisible subreports in design view (2003)

    When I add and view my sub report in design view, the lable is visible but the actual subreport is not... when previewed, the subreports are visible... I am sure I am missing some easy explanation...?

  2. #2
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Invisible subreports in design view (2003)

    Does the problem persist if you close (and save) the main report, then open it in design view again?

  3. #3
    Star Lounger
    Join Date
    Feb 2008
    Location
    philadelphia, Pennsylvania
    Posts
    72
    Thanks
    11
    Thanked 0 Times in 0 Posts

    Re: Invisible subreports in design view (2003)

    Yes, even after saving and reviewing again, the sub report is still invisible in design view... and additionally, when I add the sub report, and link the fields (date field) I get the parameter questions of start date and end date over and over and over

    When I have no sub reports, the parameter is only asked once and then the report previews

  4. #4
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Invisible subreports in design view (2003)

    Could you post a stripped down and zipped copy of the database?

  5. #5
    Star Lounger
    Join Date
    Feb 2008
    Location
    philadelphia, Pennsylvania
    Posts
    72
    Thanks
    11
    Thanked 0 Times in 0 Posts

    Re: Invisible subreports in design view (2003)

    I tried to "anonymize" the data so I could attach it, but it will not run when I do that... I found my silly mistake with the invisible issue... the sub report was completely flat and I could not see the top and bottom indicators, but I got it pulled apart and can view it now <img src=/S/brickwall.gif border=0 alt=brickwall width=25 height=15>
    but I still have the issue of the never ending parameter question when sub reports are included (they all link on the date parameter) - any thoughts on that?

  6. #6
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Invisible subreports in design view (2003)

    Create a form with a text box in which the user can enter the date, then replace the parameter with a reference to this text box in the record source of the report and subreports, e.g.

    [Forms]![frmParameter]![txtStartDate]

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •