Results 1 to 4 of 4
  1. #1
    Star Lounger
    Join Date
    Feb 2008
    Location
    philadelphia, Pennsylvania
    Posts
    72
    Thanks
    11
    Thanked 0 Times in 0 Posts

    locking subform (2003)

    I need a form that is searchable, but locked down, so no data may be altered. I have a form that the record set is snapshot view, so its data is locked. When I add a subform and view, it is fine. The moment I change any setting on the subform such as snapshot, do not allow deletions, edits etc and view the form, the form views, but the subform is blank. The title is there and the background is there, but not fields are visible. I have spent about 4 hours retrying, using different combos of controls etc and cannot get the subform fields to be visible if I put any constraints on the content.... It is not really feasable to have two different forms, due to the fields that link the records in the two different tables...Thoughts would be appreciated!

  2. #2
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: locking subform (2003)

    That is not normal behavior - it is very well possible to lock a subform by setting its Recordset property to Snapshot, or by setting Allow Edits, Allow Additions and Allow Deletions to No. However, if you do the latter, you should *not* set the Data Entry property to Yes, for the combination will result in a blank subform.

  3. #3
    Star Lounger
    Join Date
    Feb 2008
    Location
    philadelphia, Pennsylvania
    Posts
    72
    Thanks
    11
    Thanked 0 Times in 0 Posts

    Re: locking subform (2003)

    Leaving the Data Entry property set to NO, still results in a blank form.... does it mean anything that if I dont link the subform to the form, the fields WILL show in form view - but if I dont link the field, why have it as a sub form.... ?

  4. #4
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: locking subform (2003)

    There must be something wrong, but it's impossible to say what without seeing the database. Could you post a stripped down copy of your database? See <post#=401925>post 401925</post#> for instructions.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •