Results 1 to 7 of 7
  1. #1
    New Lounger
    Join Date
    Apr 2008
    Location
    United Kingdom
    Posts
    12
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Cannot compress files (XP SP2)

    I am unable to compress files in Windows Explorer. When I right click a file I do not get the option of "Send to Compressed (zipped) Folder". This has happened after a software problem that required me to repair my OS. The same problem also resulted in the disappearance of the "Add/Remove programs" in Control panel but that was solved when I did the OS repair. I suspect that the answer is reformat and start again but can anyone offer something less stressful?

  2. #2
    Super Moderator BATcher's Avatar
    Join Date
    Feb 2008
    Location
    A cultural area in SW England
    Posts
    3,413
    Thanks
    33
    Thanked 195 Times in 175 Posts

    Re: Cannot compress files (XP SP2)

    A quick Google brings up the following:

    Click Start, Run, type this command:<pre>rundll32 zipfldr.dll,RegisterSendto</pre>

    and press Enter. Worth a try?
    BATcher

    Time prevents everything happening all at once...

  3. #3
    New Lounger
    Join Date
    Apr 2008
    Location
    United Kingdom
    Posts
    12
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Cannot compress files (XP SP2)

    Thanks for the suggestion. I did this and still have the problem. I checked that the zipfldr.dll file is in the Windows/System32 folder and there are also entries in the registry. Any ideas?

  4. #4
    Super Moderator BATcher's Avatar
    Join Date
    Feb 2008
    Location
    A cultural area in SW England
    Posts
    3,413
    Thanks
    33
    Thanked 195 Times in 175 Posts

    Re: Cannot compress files (XP SP2)

    How about this one?

    Or this one? In fact, have a look in your Cocuments and Settings<yourusername>Send To folder and you should find something like the the graphic below. The "compressed" file looks like this in DIR:<pre>11/08/2004 18:13 0 Compressed (zipped) Folder.ZFSendToTarget</pre>

    and it is a zero-byte file.
    Attached Images Attached Images
    BATcher

    Time prevents everything happening all at once...

  5. #5
    New Lounger
    Join Date
    Apr 2008
    Location
    United Kingdom
    Posts
    12
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Cannot compress files (XP SP2)

    I checked the location of the Send to folder where you said it should be under my profile and it was not there. However, there was a Send to folder under the Administrator User Name so I copied it from there to my profile and the compress option works now. The weird thing is that under my username I am the administrator on my PC and yet there is another profile called administrator. I have full administrator privileges so I am confused. I suspect that the "minor software problem" I had messed other things up that I will only discover in time and therefore I may be back here with more problems!

    Thank you very much for your speedy replies and solution.

  6. #6
    Super Moderator BATcher's Avatar
    Join Date
    Feb 2008
    Location
    A cultural area in SW England
    Posts
    3,413
    Thanks
    33
    Thanked 195 Times in 175 Posts

    Re: Cannot compress files (XP SP2)

    There is usually a user called "Administrator" which has administrator privileges.

    You can set up many users with administrator privileges!

    I'm glad your problem is now solved.
    BATcher

    Time prevents everything happening all at once...

  7. #7
    Plutonium Lounger
    Join Date
    Oct 2001
    Location
    Lexington, Kentucky, USA
    Posts
    12,107
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Cannot compress files (XP SP2)

    Edited by HansV to crop picture - it was very wide

    Absolutely correct. Most people call it the built-in administrator. See attached example.
    Attached Images Attached Images
    • File Type: png x.PNG (16.3 KB, 2 views)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •