Results 1 to 4 of 4
  1. #1
    5 Star Lounger
    Join Date
    Jan 2005
    Posts
    614
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Losing inner join (Access2003)

    I have 1 table linked, one local.
    I join them by the field with different name but same TEXT datatype and I can run query fine.
    However every time I want to open query in design view - one join is lost.
    It is regular join 'where all values in both tables are equal'.

    Any ideas?
    Thanks

  2. #2
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 18 Times in 18 Posts

    Re: Losing inner join (Access2003)

    Do you get an error message when you open the query in design view?

  3. #3
    5 Star Lounger
    Join Date
    Jan 2005
    Posts
    614
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Losing inner join (Access2003)

    Yes, it says:
    MA Access can not represent join in Design view.
    One of more field can be renamed or misspelled or missing or join maybe using unsupported < or > operators.

    none of which is true for this query because i can run query
    Thanks

  4. #4
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 18 Times in 18 Posts

    Re: Losing inner join (Access2003)

    Could you do the following?

    - Open the query in design view.
    - Create the join again.
    - Select View | SQL.
    - Save and close the query while it is still in SQL view.

    What happens if you reopen the query in design view? Do you get the same error message?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •