Results 1 to 5 of 5
  1. #1
    Lounger
    Join Date
    Jul 2006
    Posts
    28
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Corruption (All)

    We are currently running an Access application from a terminal server. Each user has their own front end access database from the term serv which connects to the central backend data database on the same server.
    This program has been running fine until recently. During processing the active record on the main "Clients" table becomes corrupt. This then means that most functions become un-useable.
    I have deleted the corrupt records and C&R'd the database. It runs fine for a while then the same problem keeps coming up.
    This problem arising seems to coincide with us changing our remote desktop settings to allow a terminal session to span across 2 screens - I wouldn't think this would make a difference but though I might ask.
    I also read an article about how having two memo fields in the same table can cause issues. I have already taken one of the memo fields out of the main table and stored it in its own table.

    Does any body have any ideas as to why this corruption might be happening?!!
    In desperate need.

  2. #2
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Corruption (All)

    Access is very sensitive to interruptions in the network connection, so I'd suspect the terminal server connection.

  3. #3
    Lounger
    Join Date
    Jul 2006
    Posts
    28
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Corruption (All)

    But there is no connection because its all on the same server???

  4. #4
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Corruption (All)

    Sorry, no idea then. Memo fields don't necessarily cause corruption - many of the databases I designed have memo fields, and some of them have been in use for 9 years now without problems.

  5. #5
    Gold Lounger
    Join Date
    Jun 2001
    Location
    Crystal Beach, FL, Florida, USA
    Posts
    3,436
    Thanks
    1
    Thanked 34 Times in 34 Posts

    Re: Corruption (All)

    Could you expand on "During processing the active record on the main 'Clients' table becomes corrupt"? What kind of processing? Does it only happen then?

    Nothing else you've mentioned would seem to me to be a cause. I've never heard of that problem with multiple memo fields. And if you are using terminal server, I don't see how a lost connection would hurt you; as this is just a lost connection between your computer and the server hosting you, but this doesn't affect your session on the server which should retain its connection to the BE database.
    Mark Liquorman
    See my website for Tips & Downloads and for my Liquorman Utilities.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •