Results 1 to 9 of 9
  1. #1
    5 Star Lounger AndrewKKWalker's Avatar
    Join Date
    Apr 2001
    Location
    Cambridge, UK
    Posts
    1,020
    Thanks
    0
    Thanked 3 Times in 3 Posts

    Forms take foreever to save (2000 SP3)

    I have a form that has on it 4 combo boxes, and 2 list boxes.
    It also has a subform (but the main form is unbound).

    The Combo and list boxes come from reasonable complex queries against largish tables.

    However, although I can understand it taking a while to load the data when opened.
    Why oh why does it take up to 5 minutes to save the form.
    This only happens when making design changes when it is linked to a data file
    on the network, NOT if I move the data file locally and link it.

    My question is, What is it doing regarding the data, when I am just editing and changing the forms design,
    not opening it.
    Has anyone else experienced this annoying behavior, or is it something to do with the network.
    Andrew

  2. #2
    Super Moderator
    Join Date
    Jun 2002
    Location
    Mt Macedon, Victoria, Australia
    Posts
    3,993
    Thanks
    1
    Thanked 45 Times in 44 Posts

    Re: Forms take foreever to save (2000 SP3)

    It is a while, but yes I have had this problem. My recollection is that it happened for me even when the data was on my local machine.

    I think it is a sign of some corruption. A few things you can try:

    <UL><LI>Compact and Repair
    <LI>Decompile and Recompile - open the db using a short cut with the /decompile switch
    <LI>Import everything into a new database.
    <LI>Rebuilding the form from scratch.
    <LI>Convert the db back to 97 format, then convert back to 2000 again. (Keeping a backup copy!)[/list]
    Regards
    John



  3. #3
    5 Star Lounger AndrewKKWalker's Avatar
    Join Date
    Apr 2001
    Location
    Cambridge, UK
    Posts
    1,020
    Thanks
    0
    Thanked 3 Times in 3 Posts

    Re: Forms take foreever to save (2000 SP3)

    I have done the first three and it seems to make NO difference.

    However, when the Master and the data file are on the same local C drive, the Load time is approx 3 secs and the save time is approx 1 second.

    If the Master (still on the C drive) is linked to the data file on the Network Server, then the load time for the data is about 2 minutes,
    and the SAVE time for the form is actually between 2 to 7 minutes (it varies).
    This is why I was wondering what the heck it is doing in the background as part of the save.
    Maybe it is a Network traffic issue because there are only 7 tables in the database, and I have other databases in different locations (one with up to 100 tables) and this has NO problems at all.
    Andrew

  4. #4
    5 Star Lounger AndrewKKWalker's Avatar
    Join Date
    Apr 2001
    Location
    Cambridge, UK
    Posts
    1,020
    Thanks
    0
    Thanked 3 Times in 3 Posts

    Re: Forms take foreever to save (2000 SP3)

    On another Note, this is NOT the only database that exhibits this feature on the Server.
    Any form that comes from a large table of data does this.
    Indeed even some of the smaller ones do it.
    And only when linked to the data on the server, NOT when the data is on the local C drive.
    Andrew

  5. #5
    Gold Lounger
    Join Date
    Jun 2001
    Location
    Crystal Beach, FL, Florida, USA
    Posts
    3,436
    Thanks
    1
    Thanked 34 Times in 34 Posts

    Re: Forms take foreever to save (2000 SP3)

    This may not be it, but make sure the "Track Name AutoCorrect" feature is unchecked. You can find this by selecting Tools | Options | General Tab .
    Mark Liquorman
    See my website for Tips & Downloads and for my Liquorman Utilities.

  6. #6
    4 Star Lounger
    Join Date
    Dec 2002
    Location
    Kitchener, Ontario, Canada
    Posts
    421
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Forms take foreever to save (2000 SP3)

    I have a database that I service with a backend on the network server. It also takes forever to save. I don't think it is the size of the table, since I experience this with reports as well. It does make a considerable difference for me how many people also have the database open. The more, the worse it gets. It is definitely to do with network connections which are all voodoo as far as I'm concerned.

    If I have to do more than a simple fix, I copy the backend so I can do my work on a local machine, relink tables, do my work, then relink to the live backend and post my fixed frontend onto the server for people to update their copies.

    You could investigate whether having a form with a persistent link open makes a difference. I know it certainly makes a difference for the general speed of the database. I find I always forget to do this and unless I'm in a hurry, don't worry about too much since the client pays me by the hour <img src=/S/wink.gif border=0 alt=wink width=15 height=15> . If I have a lot of work, I take it home anyways and bring it back when I am finished.

  7. #7
    5 Star Lounger AndrewKKWalker's Avatar
    Join Date
    Apr 2001
    Location
    Cambridge, UK
    Posts
    1,020
    Thanks
    0
    Thanked 3 Times in 3 Posts

    Re: Forms take foreever to save (2000 SP3)

    This is what I have been doing, woking locally because otherwise it is horrific.
    But locally just fine. I will also check out the Autocorrect issue.
    Makes you wonder what the heck it is doing behind the scenes though, since as far as I can see, a form in design mode,
    should have very little need to do much with the data file other than get the field list out of it.
    Oh well. I might try the experiment using Access 2007 to see if it makes any difference.
    Andrew

  8. #8
    4 Star Lounger
    Join Date
    Dec 2002
    Location
    Kitchener, Ontario, Canada
    Posts
    421
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Forms take foreever to save (2000 SP3)

    The network I work on uses Access 2007. It is the same problem with the added hassle of not being able to find anything since they moved it all around. I have these problems with queries, forms and reports, although VBA modules don't seem to be much of a problem. I have noticed over the years the design view takes up gobs of memory, perhaps this has something to do with it. Also, many of my forms in this application are unbound so they shouldn't even be loading in design view.

    It is definitely something to do with the network and it could be something to do with the actual kind of network protocols being used. That is an area about which I have no clue. I know as much about networks as your average IT guy/gal knows about Access...

  9. #9
    5 Star Lounger AndrewKKWalker's Avatar
    Join Date
    Apr 2001
    Location
    Cambridge, UK
    Posts
    1,020
    Thanks
    0
    Thanked 3 Times in 3 Posts

    Re: Forms take foreever to save (2000 SP3)

    I am sure you are correct. I know next to nothing about networks either.
    I have mentioned the speed. They just say. We've a brand New Superfast server.
    My comment, 'A Ferrari is not much use in a traffic Jam' did not go down well.
    Andrew

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •