Results 1 to 4 of 4
  1. #1
    4 Star Lounger
    Join Date
    Feb 2008
    Location
    United Kingdom
    Posts
    490
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Relationships muddle (MSACCESS2003)

    I am constanly worried about queries not returning all records. I have attached a picture showing my table relationships, and if possible another picture (might have to do second message as don't know if two files can go at same time) which shows a query that returns nothing. If I just put Athletenames and Junction in the grid I still get nothing unless I change the relationships in the query grid. Can someone tell me why this happens so I can understand the reasons why. Also how to modify the query shown so that it produces the one record I am looking for. Many thanks
    Attached Images Attached Images

  2. #2
    4 Star Lounger
    Join Date
    Feb 2008
    Location
    United Kingdom
    Posts
    490
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Relationships muddle (MSACCESS2003)

    Sorry, could not find a way to put 2 pictures in thread. Thanks
    Attached Images Attached Images

  3. #3
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Relationships muddle (MSACCESS2003)

    The most probable explanation is that there is no record in the Junction table with AthleteID = 575859, or if there is, there is no record in Txclips with any of the corresponding ID2's, etc.
    You can double click the join line between AthleteNames and Junction, and specify that the query should return all records from AthleteNames and only related records from Junction.
    Similar for the other join lines. You have to select the options in a consistent way, otherwise you'll get an error message about inconsistent outer joins.

  4. #4
    4 Star Lounger
    Join Date
    Feb 2008
    Location
    United Kingdom
    Posts
    490
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Relationships muddle (MSACCESS2003)

    Thanks Hans, your explanation was fine, I checked tables and there were inconsistant records which I now have to find why. At least you have identified the problem and I am clearer. Thanks again

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •