Results 1 to 7 of 7
  1. #1
    Star Lounger
    Join Date
    Dec 2000
    Posts
    82
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Taming Character Styles (Word XP)

    I've had to reformat a very long and complex document twice now because Word keeps inserting character styles based on my basic styles. It looks as if I'm going to have to reformat for the 3rd time, and I don't know how to control this. I've unchecked "Keep Up with Styles" and "Auto Update."

    I want to control styles myself!!! Right now, I have a style that refuses to conform. It insists on conforming to the character style that Word made up instead of the paragraph style which is the basic text style for the entire document.

    If I delete the character style, it also deletes the paragraph style and sends all text marked with that style into a Normal style. Can you help me?

    Specifically, I've made all regular paragraph text Gill Sans Text Style, which is merely Gill Sans 10 regular. Now I'm getting Gill Sans Text Style Char, which is Gill Sans Small Caps 12 Bold. What a mess!!! I don't recall ever using that format, but I guess I did somewhere.

    How can I get control of styles? I use them heavily, but they are driving me crazy by changing on me. I have a job to complete. I can't play games with Word.

    The possible problem is that I bought a new computer and had to reload Word XP. Maybe I haven't found one of the places to turn off the automated changes. They're hidden all over.

    I wish I could get MS to listen to me and give me one place to check, "Yes, I want to control Word myself without your help." and turn off all the automatic changes that produce the headaches.

  2. #2
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Taming Character Styles (Word XP)

    Select Tools | Options... and activate the Edit tab. Make sure that the check box "Keep track of formatting" is OFF (cleared).

    Select Tools | AutoCorrect Options... and activate the AutoFormat As You Type tab. Make sure that the check box "Define styles based on your formatting" is OFF (cleared).

    Both check boxes, if ticked, cause Word to create styles spontaneously, without your permission.

  3. #3
    Star Lounger
    Join Date
    Dec 2000
    Posts
    82
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Taming Character Styles (Word XP)

    Those were set correctly. Is there anything else I can do to keep Word from changing my styles? If not, I'm about to decide that styles are unusable. I don't know what to do. I can't learn another program at this point. I need to deliver a product that's almost finished.

  4. #4
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Taming Character Styles (Word XP)

    If the two check boxes are off, Word shouldn't create new styles spontaneously. I don't know of another setting that could cause Word to create styles automatically.
    And if Automatically Update is not set for individual styles, they shouldn't change spontaneously, only when you edit them yourself.

  5. #5
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts

    Re: Taming Character Styles (Word XP)

    Maybe this thread will help? My ideas on Evil Word Char Char Styles (2002)

    In another post, someone recommended this article: WindowsDevCenter.com -- Hacking Word.

  6. #6
    Super Moderator
    Join Date
    Jan 2001
    Location
    Melbourne, Victoria, Australia
    Posts
    3,853
    Thanks
    4
    Thanked 259 Times in 239 Posts

    Re: Taming Character Styles (Word XP)

    Do you ever apply a paragraph style to a range of text inside a paragraph? I seem to remember that if my cursor shows as an I beam (the selection is collapsed), or the entire paragraph is selected when I apply a paragraph style then it is OK but if I have selected a word or two inside a paragraph then Word automatically creates a linked style for me - I am always careful of this and so don't ever see this problem in documents I create myself. Selecting part of two paragraphs is fine too - the paragraph style applies to both paragraphs entirely.

    I can't reproduce this linked style behaviour in Word 2007 though so I'm not sure if I'm dreaming.
    Andrew Lockton, Chrysalis Design, Melbourne Australia

  7. #7
    WS Lounge VIP
    Join Date
    Mar 2006
    Location
    Maryland, USA
    Posts
    690
    Thanks
    17
    Thanked 66 Times in 56 Posts

    Re: Taming Character Styles (Word XP)

    My experience is that as long as the char styles remain, the document will be subject to the kind of changes you describe. The macro that jscher (Jefferson) refers you to will work unless there are style names that start with " Char". (I didn't notice these kinds of char style names until about a year or two after the macro was released.) If you can manually and carefully delete the " Char" styles, the macro will usually work on the rest. The carefully part means changing the based on setting of the char style to normal before attempting to delete it. Sometimes Word won't let you delete these styles manually. An option, then, is to save the document as an XML file (for W2003) and manually edit the style definitions there. After you delete the Char styles, you may have to reapply the desired style and manual formatting to the affected text. All of this sounds like a lot, but it can be done on most of my 50 to 150 page docs in about a half hour. For me that often includes using macros to get rid of style aliases and unused user-defined styles, which I do as part of my cleanup.

    On its support site ( http://support.microsoft.com/kb/902064/en-us ), MS describes only one of the symptoms, the style names, but does a good job of describing the causes. I have not found keep track of formatting to have anything to do with causing Char styles, and the support site doesn't mention it. I nearly always paste as unformatted text and make sure that either nothing in the paragraph where I'm pasting is selected or that the whole paragraph is selected.

    HTH,
    PamC
    Pam Caswell

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •