Results 1 to 8 of 8
  1. #1
    4 Star Lounger
    Join Date
    Feb 2008
    Location
    United Kingdom
    Posts
    490
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Creating mde problems (MSACCESS2003)

    If I open a database, and try to create an MDE, and rename the MDE differently to the original database name, I have a problem when I close it. Sometimes when I close the MDE, I get a message saying it was not possible to open the database as the file was already in use. There does not seem to be an open LDB file. The more frequent message I get is:

    cannot open database (the name in here) It may not be a database that your application regognises, or the file may be corrupt

    Can anyone tell me why this keeps happening, thanks

  2. #2
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Creating mde problems (MSACCESS2003)

    Try decompiling the database (.mdb) before creating the .mde. See the thread starting at <post:=44,571>post 44,571</post:> (make sure to read about the changes needed for Access 2003).

  3. #3
    4 Star Lounger
    Join Date
    Feb 2008
    Location
    United Kingdom
    Posts
    490
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Creating mde problems (MSACCESS2003)

    Thanks Hans. I tried decompile and then compile. I imported everything into a new database. I created an mde, it opened and closed during the create an mde session. However when I open it itself, it opens okay, but again as before when I close it it gives the message unable to open ....... Why should it be opening when the database is closing? So still stuck. Regards

  4. #4
    4 Star Lounger
    Join Date
    Feb 2008
    Location
    United Kingdom
    Posts
    490
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Creating mde problems (MSACCESS2003)

    Something very strange, in fact I have vague recollection of having this before. If I use windows explorer to open the mde, I have the problem described on closing. However if I open and close the mde from a windows shortcut, there is no problem opening and closing the mde? Why, regards

  5. #5
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Creating mde problems (MSACCESS2003)

    Has the database been set to Compact on Close?

  6. #6
    4 Star Lounger
    Join Date
    Feb 2008
    Location
    United Kingdom
    Posts
    490
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Creating mde problems (MSACCESS2003)

    The original db is set to compact on close, so would imagine it follows through on mde version. Thanks

  7. #7
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Creating mde problems (MSACCESS2003)

    Sometimes Compact on Close has problems, so try turning it off to see if the problem goes away.

  8. #8
    4 Star Lounger
    Join Date
    Feb 2008
    Location
    United Kingdom
    Posts
    490
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Creating mde problems (MSACCESS2003)

    Many thanks Hans, yes it works okay if I don't compact on close?, so I will leave it that way. Have a good weekend, regards

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •