Results 1 to 5 of 5
  1. #1
    Bronze Lounger
    Join Date
    Jan 2001
    Location
    Virginia, USA
    Posts
    1,560
    Thanks
    37
    Thanked 1 Time in 1 Post

    Open linked images (2007)

    I've created some documents that contain hyperlinks to photos. When I try to open the linked photo, Internet Explorer first launches a new blank tab, then launches a second instance of itself to display the photo. The default viewer for JPEGs in my system is Office Picture Viewer, and that's what displays photos when I double-click on them from Windows Explorer. How do I train Word 2007 to use the default viewer to display linked photos?

  2. #2
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Open linked images (2007)

    Try the following:
    - Quit Excel.
    - Start Regedit.
    - Navigate to HKEY_LOCAL_MACHINESoftwareMicrosoftOffice9.0Common Internet.
    - Create a new DWORD value, name it ForceShellExecute and give it the value 1.
    - Start Excel and click a hyperlink to a picture to check whether it opens in Office Picture Viewer.

    Alternatively, download the attached zip file, extract the reg file from it and open the reg file.

    (Note: 9.0 is the internal version number of Office 2000, but this registry entry affects later versions of Office too. Do *not* change 9.0.)
    Attached Files Attached Files

  3. #3
    Bronze Lounger
    Join Date
    Jan 2001
    Location
    Virginia, USA
    Posts
    1,560
    Thanks
    37
    Thanked 1 Time in 1 Post

    Re: Open linked images (2007)

    I followed the path through Regedit. I did not see "Office9.0," but I did find 12.0CommonInternet and proceeded from there. Then I restarted Word, clicked a link to a photo, and saw the same behavior I described earlier. Internet Explorer 7 launched and displayed the photo.

    Whereas I did not see anything like 9.0 in Regedit, I did not attempt to launch the attachment.

  4. #4
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Open linked images (2007)

    You should either try the reg file in the attachment, or do the following in RegEdit to create the entire path:

    - Navigate to HKEY_LOCAL_MACHINESoftwareMicrosoftOffice.
    - With Office selected, create a new key and name it 9.0
    - With 9.0 selected, create a new key and name it Common
    - With Common selected, create a new key and name it Internet
    - With Internet selected, create a new DWORD value and name it ForceShellExecute
    - Double-click the ForceShellExecute value in the right hand pane and set its value to 1

  5. #5
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts

    Re: Open linked images (2007)

    Windows XP, I presume. What is your file type setting for URL:HTTP? From Windows Explorer:

    Tools > Folder Options > File Types > select URL:Hypertext Transfer Protocol > Advanced > select Open > Edit.

    These are the two most interesting settings (obviously yours and mine won't t match):

    Application: "C:Program FilesMozilla Firefoxfirefox.exe" -requestPending -osint -url "%1"
    DDE Message: "%1",,0,0,,,,

    (Note: to post %1 in the Lounge you need to put [square brackets] around the % sign.)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •