Results 1 to 4 of 4
  1. #1
    2 Star Lounger
    Join Date
    Feb 2003
    Location
    Melbourne, Victoria, Australia
    Posts
    139
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Specific version of Sun Java required (XP Corp SP2)

    Hope this is the appropriate area.
    I have a Web based application that requires a specific version of the SUN Jre (1.4.2) to work correctly, however some of the users have installed/updated to a later version 1.6.7 and hence the application doesn't do what it is supposed to do.
    We use AD in our Windows environment and I was wondering if there was a way to limit a specific group of users to not install a later version of the the JRE or if they do have multiple versions installed, to somehow activate 1.4.2 when they run/start the Web application using Internet Explorer rather than defaulting to the latest JRE install.
    Can anything be set in Group Policies, or initiate the Web application via a batch file which somehow uses the 'older' JRE, or any other suggestions?

    Regards
    Zinger

  2. #2
    Silver Lounger
    Join Date
    Apr 2001
    Location
    New York, New York, USA
    Posts
    2,328
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Specific version of Sun Java required (XP Corp SP2)

    You have to disable corresponding Java Plug-in ActiveX Controls for your users.

    For more information see How to manage Internet Explorer add-ons in Windows XP Service Pack 2, "Managing add-ons by using registry entries and Group Policy" paragraph.

  3. #3
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,577
    Thanks
    5
    Thanked 1,057 Times in 926 Posts

    Re: Specific version of Sun Java required (XP Corp SP2)

    You can have multiple versions of the JRE installed concurrently. Did they uninstall the 1.4.2 version? We have several machines with multiple versions of the JRE installed and AFAIK there has not been a problem with the application that requires the older version.

    Joe
    Joe

  4. #4
    2 Star Lounger
    Join Date
    Feb 2003
    Location
    Melbourne, Victoria, Australia
    Posts
    139
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Specific version of Sun Java required (XP Corp

    Thanks for the response.
    The application that is having the issues is Business Objects XI (BOXI) R2, WebIntelligence via Infoview, a BI suite of tools.
    If there is no JRE on the workstation then the BOXI web server pushes down the 1.4.2 from the server, however if the workstation has the JRE installed it uses that version with later versions than 1.4.2 displaying different behaviour, like prompts/pick lists not displaying. The BOXI/SAP tech support site advises that 1.6.7 is NOT currently supported.
    I'm not sure if users have multiple version of the JRE, but am making the assumption if they do, then the latest download/upgrade would be the default.
    I have also been advised that other applications require the later version of the JRE (1.6.7).
    If there are multiple versions on the workstation, is there a way of using the appropriate one dependent on whichever web app is being used.
    If two web apps are open, each requiring a different version of the JRE; is it at all possible to have two different version of the JRE running at the same time.
    ZInger

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •