Page 1 of 2 12 LastLast
Results 1 to 15 of 19
  1. #1
    5 Star Lounger
    Join Date
    Aug 2006
    Posts
    784
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Recording sound (Vista 64-bit)

    Whenever I want to record something from my computer (song, internet call, soundtrack), I let the volumen come through the computer’s speakers (as opposed to external earphones), plug in an external microphone, and record using the Windows Sound Recorder. However, there is always a background hissing noise and if someone walks into the room or starts talking, that sound will be picked up.

    Is there a way to record sound “internally,” without having to cause the sound to come out through the speakers and then in again through a microphone, such that external disturbances and that hissing sound won’t be picked up?

    Regards,

    JMT

  2. #2
    Plutonium Lounger Leif's Avatar
    Join Date
    Dec 2000
    Location
    U.K.
    Posts
    14,010
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Recording sound (Vista 64-bit)

    I think you should be able to record 'internally'. Does this How-to help?

  3. #3
    5 Star Lounger
    Join Date
    Aug 2006
    Posts
    784
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Recording sound (Vista 64-bit)

    Following the instructions for Windows Vista, I right-click on the background of the Recording tab and choose "show disabled devices," but Wave Out Mix doesn't show up.

    Is it possible that Wave Out Mix doesn't come with Windows Vista Home Premium?

    JMT

  4. #4
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Recording sound (Vista 64-bit)

    It should be available in any version of Windows Vista.

    Which devices are listed after you specify that you want to show disabled devices? No "Stereo Mix" or "Mono Mix" either?

  5. #5
    3 Star Lounger
    Join Date
    Feb 2003
    Location
    Runcorn, Cheshire, United Kingdom
    Posts
    372
    Thanks
    0
    Thanked 2 Times in 2 Posts

    Re: Recording sound (Vista 64-bit)

    BIG thanks for that Leif.
    How stupid to disable the device by default - why on earth would they do that?

  6. #6
    5 Star Lounger
    Join Date
    Aug 2006
    Posts
    784
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Recording sound (Vista 64-bit)

    Hans, the only options I get are in the attached image. Under the playback tab, though, I get a Bluetooth device adn I don't even know what it is. But I don't think that affects anything in the recording tab.

    Regards,

    JMT
    Attached Images Attached Images

  7. #7
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Recording sound (Vista 64-bit)

    You replied to Owen (Gfamily), not to me.

    I'm afraid I can't help, I'm still using Windows XP.

  8. #8
    3 Star Lounger
    Join Date
    Feb 2003
    Location
    Runcorn, Cheshire, United Kingdom
    Posts
    372
    Thanks
    0
    Thanked 2 Times in 2 Posts

    Re: Recording sound (Vista 64-bit)

    When you right click on that tab you should get the following options
    Show disabled devices
    Show disconnected devices

    Tick the option to show disabled devices, You should get another device called Stereo Mix or Line Mix or similar.
    Double click to open the device controller and change the option to enable the device.
    Attached Images Attached Images

  9. #9
    5 Star Lounger
    Join Date
    Aug 2006
    Posts
    784
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Recording sound (Vista 64-bit)

    Dar Owen,

    I tried that but the only devices that are showing are the Headset microphone and the Microphone, as shown, Are there any other ways to enable "internal" recording?

    Regards,

    JMT

  10. #10
    3 Star Lounger
    Join Date
    Feb 2003
    Location
    Runcorn, Cheshire, United Kingdom
    Posts
    372
    Thanks
    0
    Thanked 2 Times in 2 Posts

    Re: Recording sound (Vista 64-bit)

    2 suggestions

    First thing I can suggest is to see f there are any updates available for your audio drivers. My daughter's laptop (Dell Inspiron bought in 2006 & running XP) didn't seem to have an Internal Mix device until we downloaded a driver upgrade. XP is different in that it doesn't disable and hide these devices, but she definitely needed an upgrade before she could record from the internal mix.

    My second suggestion is to buy/make a patch cable with a mini-stereo plug on each end so that you can run it between the headphone and microphone sockets. This should cut off any internal microphone and mean that you only get the sounds from the PC itself.

    One thing that's worth doing is bring up the mixer panel and reduce the sound levels for "Windows sounds" to zero. This means you shouldn't get those 'dinks' and chimes recorded on top of your own recordings.
    ========================
    On following up searches for your particular driver, there are reports from others that some manufacturers have deliberately disabled the Stereo Mix device on soundcards. Manufacturers mentioned are HP and Sony. Official responses confirming that 'this functionality has been disabled by design and we are unable to help further' don't tend to give reasons, but it has been suggested that it is to prevent recording of streaming audio sources. Some people have installed an XP partition and been able to use the Stereo Mix, but I'm not sure if there is an XP driver for your audio components.

  11. #11
    5 Star Lounger
    Join Date
    Aug 2006
    Posts
    784
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Recording sound (Vista 64-bit)

    Thank you for your reply. I am using an HP Pavilian Laptop with Windows Vista Home Premium and Service Pack 1. Would I be looking for drivers for my microphone (Conexant Hight Definition SmartAudio 221) or for my sound card? If it is the latter, how can I figure out the model/make of my sound card in order to google potential patches?

    Regards,

    JMT

  12. #12
    3 Star Lounger
    Join Date
    Feb 2003
    Location
    Runcorn, Cheshire, United Kingdom
    Posts
    372
    Thanks
    0
    Thanked 2 Times in 2 Posts

    Re: Recording sound (Vista 64-bit)

    Hi - sorry about the delay, I was away for the weekend.

    I can't give any solid recommendations as regards drivers because there is a risk that you could trash your sound card. However, it may be the case that HP have installed a cut down version of the drivers to restrict access to the Stereo Mix. (Equally, they may have disabled the Stereo Mix in the hardware, but I would be more surprised if this was the case).

    What I am about to suggest is what I would do if it was my laptop. Before I started I would make sure I had everything backed up because there is a risk that this will not work and you will end up with having to reinstall the OS and all the drivers . So long as you are aware of the risks.

    If it was my system I would first visit the HP site and look to download the installation files for the official HP drivers for the soundcard - "Conexant Hight Definition SmartAudio 221" is the driver for the sound card, not just the microphone.

    Once I had the HP downloaded drivers in case I needed to re-install, I would then visit one of the driver download sites (I can't recommend any I'm afraid) and look for some generic Vista (x64) drivers to download for this card.

    I'd take a System Restore checkpoint.
    Then install the generic driver
    Go to Control Panel | Sounds | Recording and right click to see if the Stereo Mix is available (enable it if it is disabled)
    Check everything else is working OK

    If that doesn't work, perform a System Restore to get back to the correct drivers or reinstall the official HP drivers from the file I downloaded before.
    Or reinstall Vista if needed.

    ================
    Have you tried using the patch cable to link your headphone and microphone sockets?

  13. #13
    5 Star Lounger
    Join Date
    Aug 2006
    Posts
    784
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Recording sound (Vista 64-bit)

    Hello again,

    I checked on my old computer and did find on that one an option for "Steroi Mix" (see attached), which I enabled. HOwever, I can't select that device as the default device. Even when I select it, "Set default" remains greyed out. Thus, when I record sound in Sound Recorder, I am still getting the problem where background noises are being picked up. How can I get this to work?

    Regards,

    JMT
    Attached Images Attached Images

  14. #14
    3 Star Lounger
    Join Date
    Feb 2003
    Location
    Runcorn, Cheshire, United Kingdom
    Posts
    372
    Thanks
    0
    Thanked 2 Times in 2 Posts

    Re: Recording sound (Vista 64-bit)

    Is this on the machine you want to record from?

    Go to the 'sound' icon in the Task Bar and double click it - you should get up a slider for the speaker volume - at the bottom of which is a link to 'mixer'. Select that and it will bring up a primitive mixing desk with a slider and mute control for each device or sound producing program active on your machine.

    Click the mute control against your microphone and also against the 'Windows sounds'.

    Try now - you should be able to record what you need.

  15. #15
    5 Star Lounger
    Join Date
    Aug 2006
    Posts
    784
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Recording sound (Vista 64-bit)

    Edited by HansV to reduce size of screenshot

    Hello,

    The settings you describe are present on the new computer (which doesn't have Sterio Mix, Mono MIx, or Wave Out MIx), but not on the old computer (which has Sterio Mix), on which the Sound icon has apparently been replaced with a Realtek HD Audio Manager icon, which, when I double click it, opens up a window with a vast array of tabs and options (see attached).

    I went to the Stereo Mix tab and clicked "Set Default Device," and then experienced the problem of having no volume (whether or not my headset was plugged in), but that problem was solved after a restart.

    I then ran some tests and it worked: my computer can now record without the interference of outside noises.

    I made the following observations:
    (i) The sound recorder records with good quality, regardless of whether I have my earphones plugged in or whether the sound is coming out of the speakers;
    (ii) External sounds are not picked up regardless of whether an external microphone is picked up;
    (iii) The volume of the sound coming out of the computer (whether or not headphones are plugged in) does affect the recording. For example, if the sound is on mute, then the recorder will not pick it up; if the sound is loud, then the recording will be loud. I was a bit surprised by this
    (iv) However, changing the volume on external headphones does not affect the sound recording. Thus, you can have the sound on the computer set to really loud and the volume on the headphones to really low, and the recording will come out loud.
    Thus, I recommend keeping the volume up high on the computer and plugging in headphones so you won't harass your neighbors. This way, you can get a good loud recording (it can never be too loud because you can always turn down the volume when listening to it; but it can be too low becuase you can only turn the volume up so far).
    Regards,

    JMT
    Attached Images Attached Images
    • File Type: jpg x.jpg (35.3 KB, 2 views)

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •