Results 1 to 10 of 10
  1. #1
    5 Star Lounger
    Join Date
    Aug 2006
    Posts
    784
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Word doesn't save (2003)

    Hello,

    I appear to have a serious problem. I have an important 100 page document and Word won’t let me save my changes. If I press ctrl + S, the save doesn’t register, because when I then go to close the document, Word asks if I want to save the changes. When I select “Yes,” nothing happens. I try closing it again, and Word again asks if I want to save the changes. The only way to close the document is to select “No.”

    Saving the document as a new document similarly doesn’t work. I go to File/Save as… and no dialogue box opens.

    Someone, please tell me there is hope…

    JMT

  2. #2
    Star Lounger
    Join Date
    Jun 2008
    Location
    Baltimore, Maryland, USA
    Posts
    90
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Word doesn't save (2003)

    Until you get the inevitable informed advice from a more-knowledgeable lounger than I, just to ensure that you preserve the main content of the document, you could Select All (Ctrl + A) and copy and paste it to any other program that will take it and let you edit it - Wordpad, or even an e-mail message, if it has the capacity. You may or may not lose some formatting, but at least you would save the text.

  3. #3
    Silver Lounger
    Join Date
    Jul 2001
    Location
    Ottawa, Ontario, Canada
    Posts
    1,609
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Word doesn't save (2003)

    Create a new document.
    In your problematic document add several empty paragraphs at the end.
    Select everything except the last paragraph and copy the selection.
    Select the new document and paste.

    You should now be able to save the new document with everything intact except for: the attached template, and any VBA code.
    Regards
    Don

  4. #4
    3 Star Lounger
    Join Date
    Mar 2003
    Location
    Elkins Park, Pennsylvania, USA
    Posts
    325
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Word doesn't save (2003)

    If you'd like to try and investigate what may have happened, I'd suggest ruling out VBA code hijacking your commands by selecting Tools: Macro>Macros, then select Word Commands from the Macros in... drop-down, and, from the list of available macros, select either FileSave or FileSaveAs and see if it behaves appropriately. If it does, then there might well be code lurking in either the document or its attached template that hijacks the command. (An alternative to this could be launching the VBA editor [Alt-F11], then, if necessary, selecting View: Immediate Window if it's not already open, and then typing the command ActiveDocument.Save in the Immediate window and hitting ENTER.)

    Another possiblity is that the file IS being saved, and that the Close event is triggering some other code that registers (correctly or not) a subseqent but irrelevant change in the file. I wouldn't be surprised if conflicts in or between add-ins can cause this, as I have seen many compatibility issues between commercially purchased add-ins (Adobe Acrobat, Reference Manager, SnagIt, etc.) in my years of working with Word.
    <font face="Comic Sans MS">That's what you do in a herd; you look out for each other!</font face=comic> - Mike

  5. #5
    5 Star Lounger
    Join Date
    Aug 2006
    Posts
    784
    Thanks
    0
    Thanked 0 Times in 0 Posts

    NEW PROBLEM

    I think what happened is that my template was corrupted. So I opened it and saved it under a different name and then reattached it with the new name and then was able to save my document.

    I don’t know how my template got corrupted, and I fear the problem may still be in the new saved version but I guess for now I am okay until further notice …

    Mesaka, I wish I would have tried that trick before I resolved the problem to see if I could have gotten some info. Now that the problem is resolved, though, those commands work in the Macro dialogue (as well as directly through the file menu).

    Then I had a NEW PROBLEM: I couldn't stop all of my field codes from displaying. Normally, all I had to do was press the Show/Hide Paragraph formatting icon to get rid of the field codes, but it wasn't working. Then I restarted and now they are finally gone.

    Regards,

    JMT

  6. #6
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: NEW PROBLEM

    You can press Alt+F9 to toggle field codes on/off. The Show/Hide ¶ button has nothing to do with field codes, it toggles the display of non-printing characters such as paragraph marks.

  7. #7
    5 Star Lounger
    Join Date
    Aug 2006
    Posts
    784
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: NEW PROBLEM

    Perhaps I was using the wrong terminology. Do fields code not include the hidden codes for manually marking TOC and index entries? Those are what I was referring to and I couldn't get rid of them by pressing the Show/Hide Paragraph mark as I usually could.

    Regards,

    JMT

  8. #8
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts

    Re: NEW PROBLEM

    I suspect you have Hidden Text toggled to display at all times. The button on the toolbar toggles the Show All checkbox on the Tools>Options>View tab. You will see there that you can manually choose to display or not display items, and those selections persist after you turn off "Show All."

  9. #9
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: NEW PROBLEM

    As Jefferson Scher notes, the display of TC and XE fields depends on whether you show hidden text or not.

  10. #10
    5 Star Lounger
    Join Date
    Aug 2006
    Posts
    784
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: NEW PROBLEM

    Actually, I think that my computer just had too little memory to toggle the hidden text (and TOC and Index entries) off. Today, the same thing occurred and the problem disappeared after closing and reopening the document.

    But next time the problem appears I will go to Tools/Options/View to check it out.

    Regards,

    John

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •