Results 1 to 5 of 5
  1. #1
    New Lounger
    Join Date
    Nov 2008
    Location
    Haifa, Haifa District, Israel
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Help me disable French Dictionary

    I wish to disable totally the French Custom Dictionary in Word 2003. It constantly keeps popping-up and gives false spelling errors while I spell-check English texts. I removed the French in the ‘Microsoft Office Language Settings’ in Office Tools. I changed the custom dictionary from French to English in ‘Word’, I made sure that French is nowhere set in ‘Regional & Languages’. But to no avail, the French dictionary keeps coming back! I have been advised to 'Open normal.dot and change the default language' but I do not how to do it nor how or where to find the normal.dot. I do apologize for my ignorance but please I need step-by-step instructions.

  2. #2
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts

    Re: Help me disable French Dictionary

    I thought there was only one Custom dictionary, but I have the North American English version of Office, so I might be missing some features.

    Are you sure there is no French (France) text in your document? This is a format applied at the character level. It could be part of a style definition in your Normal template that affects all new documents, or it could be something that's simply been carried forward from old documents when you use Save As.

    To search for French text you can use the Find dialog. Click More if needed to show the lower half of the dialog, then Format > Language. Or try this macro:

    <code>Sub FindFrenchFrance()
    Selection.HomeKey wdStory
    With Selection.Find
    .ClearFormatting
    .LanguageID = wdFrench
    'Application.CheckLanguage = False
    .Text = ""
    .Replacement.Text = ""
    .Forward = True
    .Wrap = wdFindContinue
    .Format = True
    .MatchCase = False
    .MatchWholeWord = False
    .MatchWildcards = False
    .MatchSoundsLike = False
    .MatchAllWordForms = False
    If .Execute Then
    MsgBox "I found some French language text in this document!"
    End If
    .ClearFormatting
    End With
    End Sub</code>

  3. #3
    Star Lounger
    Join Date
    May 2007
    Location
    Gloucester, Gloucestershire
    Posts
    60
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Re: Help me disable French Dictionary

    Could this have something to do with the "Set language automatically" check box under Tools | Language | Set Language? I had something similar when I spell-checked a document and it reported some Swedish spellings (apparently because the text included the word "tag" - Swedish for "day"). If you switch off the automatic language detection, the problem should no longer occur.

    Anne

  4. #4
    Silver Lounger
    Join Date
    Oct 2002
    Posts
    1,993
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Help me disable French Dictionary

    Gutten Tag Anne,

    I saw that! <img src=/S/grin.gif border=0 alt=grin width=15 height=15> That would be German not Swedish if you mean "day". <img src=/S/smile.gif border=0 alt=smile width=15 height=15> "Tag" in Swedish (but not a short "a") means "take" in English, very similar as you see:

    English: take a cake (or I would say; please have cake/cookie)
    Swedish: tag en kaka

    On topic <img src=/S/grin.gif border=0 alt=grin width=15 height=15>:
    I agree it can many times be the "Detect language automatically" in the dialog box you mentioned. But I still have my checked, as default. It is many times a quick affair to select all Ctrl-A, and double click on the status bar to change/set the language for the whole document.

    To the OP, syrose:
    I am no Word expert, but have you checked/changed the Default language in the dialog box, mentioned by Anne (when discussing auto detection): Tools | Language | Set Language | Default... button?

    Pick your language in the list above before you do this, the following dialog then says:
    The change will affect all new documents based on the NORMAL template. As I see it, that is one simple way to change normal.dot.

    But I agree with both Jefferson and Anne, it could be just a few words interpreted as French, due to auto detect.

  5. #5
    2 Star Lounger
    Join Date
    Nov 2005
    Location
    Monkton, Maryland, USA
    Posts
    117
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Help me disable French Dictionary

    This applies to MS Word 2007.

    When you enter text into your Word document that is something other than English, chances are that MS Word will not recognize and will interpret it as being misspelled.

    MS Word is programmed to automatically proofread your document for the language version that is installed on your computer. If you purchased your licensed copy of MS Word in the US, your text will be marked as English (U.S.) and Word will proof non-English text against the English dictionary.

    When you add text in a language other than English, Word's spelling and grammar checker will flag them as being misspelled. To let Word know which dictionary to use to proof the text, you should mark it for proofing in its own language by assigning a style.

    Key in the foreign language text.
    Select the text.
    Go to Tools | Language | Set Language.
    Scroll to and select the language from the Mark Selected Text As list.
    Click OK.
    Go to View | Task Pane.
    Click the Getting Started arrow and select Styles and Formatting from the list.
    With the text still selected, click New Style.
    Enter a Name for the style in the Name box.
    Click OK.

    Now when you want Word to proof your text in that language, simply highlight the text and select the name from the drop-down Style box in the Formatting toolbar. This new style will be available to the current document only. If you want it to be available to the template the document is based on, click the Add To Template check box in the New Style dialog box after step 9 before clicking OK.

    http://www.carolscorneroffice.com

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •