Results 1 to 2 of 2
  1. #1
    Star Lounger
    Join Date
    Aug 2002
    Wichita, Kansas, USA
    Thanked 0 Times in 0 Posts

    SendMail in Word 2007 not working (VBA Word 2007)

    I have an active x button control. The code behind the button is "activedocument.sendmail".

    When I have this button in conjunction with a form, and I have protected the document for "filling in forms", the email button quits working and I can't do anything else in the document.
    This all worked ok in Word 2003.
    It may work once or twice when first creating the document, but after I exit and come back in, I can click on the button and nothing happens. Then I cannot type in the form fields in the document. I cannot get to visual basic or to design mode. If I remove protection from the document, sometimes two buttons show up on the screen, but I cannot change anything on them or do anything with them.
    Originally I brought in a document from Word 2003 that was working correctly, into Word 2007 and made some modifications to the form. That is when I first noticed the problem. Then I tried creating a new document, just adding a couple of form fields to the document along with an "email button" and am having the same problems occur.

    Any ideas?


  2. #2
    Plutonium Lounger
    Join Date
    Mar 2002
    Thanked 28 Times in 28 Posts

    Re: SendMail in Word 2007 not working (VBA Word 2007)

    Do you have any add-ins installed in Word 2007? If so, you could try starting Word without add-ins by typing
    winword /a
    in the Start | Run... box, to see if the problem disappears.

    See Phil Rabichow's <!post=Systematic Approach to Behavioral Problems in Word,197827>Systematic Approach to Behavioral Problems in Word<!/post> for more info, although it hasn't been updated for Word 2007 (for example, the default template for Word 2007 is Normal.dotm instead if

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts