Results 1 to 4 of 4
  1. #1
    5 Star Lounger
    Join Date
    May 2001
    Location
    Patterson Lakes, Melbourne, Victoria, Australia
    Posts
    637
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Replication error (XP SP3)

    When I open the design master of a replica set I get the following error, which has me perplexed.
    ‘This member of the replica set has conflicts from synchronizing changes with other members.
    Do you want to resolve these conflicts now?’
    Selecting ‘Yes’ to resolve the conflict brings up the conflict dialog, but there are no conflict tables.
    I have deleted all replicas and removed them from the replica set. I still got the same error. I re-created the 2 other replicas and still got the same error.
    Help.
    Regards,
    Peter

  2. #2
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Replication error (XP SP3)

    See if MSKB article Microsoft Replication Conflict Viewer displays “<No conflict tables>” even when synchronization conflicts exist among the replicas in Microsoft Access helps. It suggests that you have to delete some system tables manually. Be careful when you do this!

  3. #3
    5 Star Lounger
    Join Date
    May 2001
    Location
    Patterson Lakes, Melbourne, Victoria, Australia
    Posts
    637
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Replication error (XP SP3)

    Thanks Hans, but that solution presupposes that there are tables that are in conflict and that each have a <tablename>_Conflict table placed in the design master. There are none, the only conflict table is MySysConflicts, which is what I would suspect if I had deleted all replicas (there are only 2) and removed them all from the replica list. Quite perplexing.
    Whoops I just revealed hidden objects and there are conflict tables there after all.
    Regards,
    Peter

  4. #4
    5 Star Lounger
    Join Date
    May 2001
    Location
    Patterson Lakes, Melbourne, Victoria, Australia
    Posts
    637
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Replication error (XP SP3)

    Thanks for that Hans. I removed both replicas then removed all entries in the <tablename>_Conflicts tables, then re-created the replicas and all works beautifully.
    Attached Images Attached Images
    Regards,
    Peter

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •