Results 1 to 5 of 5
  1. #1
    3 Star Lounger
    Join Date
    Jun 2002
    Location
    Duluth, Minnesota, USA
    Posts
    215
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Boot Up Choice (XPsp2 I think)

    Sorry for the lame start to this question. I have incomplete information but will update as soon as possible. I have a friend who has asked me for help with a start up question on her laptop PC. She says that when she boots up, she is asked to choose between two versions of OS. I believe she is running XP with SP2. She says that she just waits and it eventually defaults to one of the selections and continues with bootup.

    Her question is how to get rid of the selection process and speed the boot procedure.

    Any ideas?

    Thanks,

    Douglas

  2. #2
    Silver Lounger
    Join Date
    Oct 2002
    Posts
    1,993
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Boot Up Choice (XPsp2 I think)

    As you may have heard this is done in the boot.ini file.

    What she sees can be a result of: two (or several) versions of OS installed; the Recovery Console is installed (thus becoming a choice in the boot menu) or a glitch that has somehow corrupted the boot.ini file slightly (i.e. there are two entries but only one OS).

    The simple way to run the default OS at start (without modifying the boot.ini) is to disable the boot menu (it will not correct what is in there, but it will not ask for a choice, just go for the default). Since I don't think she suddenly installed an OS <img src=/S/smile.gif border=0 alt=smile width=15 height=15> (I assume this is a new occurrence) or the RC, it may be a glitch that has corrupted the boot.ini slightly.

    If she has another older OS, a simple disable of the boot menu is OK.

    Disable:
    Right-click My Computer and click Properties.
    On the Advanced tab, click Settings under Startup and Recovery.
    Uncheck the box for show list of OS.

    If you want to edit the boot.ini to correct whatever problem there is see among other: http://support.microsoft.com/kb/289022

    But do come back if you have more info or questions.

  3. #3
    Plutonium Lounger
    Join Date
    Oct 2001
    Location
    Lexington, Kentucky, USA
    Posts
    12,107
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Boot Up Choice (XPsp2 I think)

    Let's start by taking a look here. Go to My Computer, Properties, Advanced, and click the Settings button under Startup and Recovery. Now click the button To Edit the startup options... and see if you have a Boot.Ini file and if it looks anything like this:
    <hr> [boot loader]
    timeout=30
    default=multi(0)disk(0)rdisk(0)partition(2)WINDOWS
    [operating systems]
    multi(0)disk(0)rdisk(0)partition(2)WINDOWS="Window s XP Media Center Edition" /NOEXECUTE=OPTIN /FASTDETECT <hr>
    You may find more than one "entry" so let us know what you see. I don't have a machine with more than one entry, so I don't remember how to tell which one needs to be deleted. You don't need to SAVE the file until someone here talks to you for followup.

    Edited. Oops, sorry Argus. I was evidently right behind you.

  4. #4
    Uranium Lounger
    Join Date
    Mar 2001
    Location
    New Jersey
    Posts
    6,684
    Thanks
    1
    Thanked 11 Times in 11 Posts

    Re: Boot Up Choice (XPsp2 I think)

    Was the laptop upgraded from another OS or did someone reinstall XP ?? The 2 OS boot option issue usually is a result of something like this. If the other OS is no longer on the machine or XP was reinstalled, you need to determine which of the options you want to keep and then edit the other from the Boot.ini file.

    To edit the boot.ini file, Boot.ini is a hidden file and not visible generally.
    To unhide it. Do the following:
    1. Open My computer

    2. Click on Tools. Go to Folder options

    3. Click View tab and among the boxes, check "show hidden files and folders" box and uncheck "Hide extensions for known file types" and also uncheck "Hide protected operating system files".
    Hit Apply and OK

    4. Now browse to Local Disk C: and rightclick on Boot.ini and chose properties

    5. Uncheck Read Only attribute at the bottom, if exists

    6.Now open Boot.ini file and u can make changes to it.
    Under [Operating System]
    Delete the line with the OS you no longer want/need, but <font color=red>make sure you know what you are doing because if you make a mistake, you may make the PC unbootable.</font color=red>
    7. Save the file and restart the machine.
    <IMG SRC=http://www.wopr.com/w3tuserpics/DocWatson_sig.gif>

  5. #5
    Silver Lounger
    Join Date
    Oct 2002
    Posts
    1,993
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Boot Up Choice (XPsp2 I think)

    Of course no problem Al. There are several ways to deal with this one.

    Though I think I travelled two times around the Internet <img src=/S/laugh.gif border=0 alt=laugh width=15 height=15> to find the English wording next to the first check box in the Startup and Recovery dialog box to spare the OP from my translation, of course I didn't have the patience to do a thorough search at the right places.

    It may very well be that the PC has an old OS but the PC is new to the user. On the other hand a slightly corrupted boot.ini means a simple edit plus some general checks of the health of the PC.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •