Results 1 to 11 of 11
  1. #1
    Star Lounger
    Join Date
    Oct 2006
    Location
    Albany, New York, USA
    Posts
    72
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Strange results in report (Access 2007)

    Hi Folks,
    I have an Access database that I created in Access 2003, using the Access 2000 file format. I use this to print address labels.
    I have a table of names addresses and phone numbers.
    One of the table’s fields is a check box that is used by a query to select the records that I want to print on the labels.
    I have a report that runs against this query that prints the selected (checked) records onto the address labels.
    I have been using this database for years and it worked flawlessly, that is until I bought Office 2007.
    When running this database in Access 2007, if I check the checkbox of a different record in the table, and then run the report, the record does not show up in the report. I can go back into the table and see that the record is still checked.
    However, if I close the database, re-open it and run the report the newly checked record is there. I never had to do this before, am I missing something? Anyone have any ideas?

  2. #2
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Strange results in report (Access 2007)

    Where do you tick the check box? Directly in the table or in a form based on the table?

  3. #3
    Star Lounger
    Join Date
    Oct 2006
    Location
    Albany, New York, USA
    Posts
    72
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Strange results in report (Access 2007)

    Directly in the table.

  4. #4
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Strange results in report (Access 2007)

    Have you made sure to move to a different record (or to close the table) after ticking the check box? If the table is still open on the same record, the change will not have been saved to disk yet.

  5. #5
    Star Lounger
    Join Date
    Oct 2006
    Location
    Albany, New York, USA
    Posts
    72
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Strange results in report (Access 2007)

    Thanks for the quick reply Hans. I saved and closed the table before running the report, but the newly checked record still does not appear on the report unless I close and re-open the database. I have done this several times now, this action is consistent. Never seen anything like this before.

  6. #6
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Strange results in report (Access 2007)

    That's strange. I hope that someone who has Access 2007 can help (I'm still using 2002 and 2003).

  7. #7
    Star Lounger
    Join Date
    Oct 2006
    Location
    Albany, New York, USA
    Posts
    72
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Strange results in report (Access 2007)

    Hi Hans and thanks again.
    I am using Access 2003 at work where I developed the database, but have version 2007 at home where I'm having the problem. Works fine at work. Works fine at home (fast too) once it's closed and re-opened.

  8. #8
    Star Lounger
    Join Date
    Oct 2006
    Location
    Albany, New York, USA
    Posts
    72
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Strange results in report (Access 2007)

    Nothing huh? Thought it may be a glitch in 07. It must be a problem with my database or installation. Thanks anyway folks I appreciate your attention to the matter. Guess I'll try to repair and if that don't work, re-install.

  9. #9
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Strange results in report (Access 2007)

    I'd wait a bit to see if someone else replies. It's only been a few hours, and we have Loungers in all time zones.

  10. #10
    Gold Lounger
    Join Date
    Feb 2001
    Location
    Sint Niklaas, Belgium
    Posts
    2,778
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Strange results in report (Access 2007)

    I tried a similar scenario with Access 2007 and all worked OK.
    Maybe you can post a stripped version of your db to see if we have the same problem as you with your db on our Access 2007.
    See <post#=401925>post 401925</post#> for instructions to attach the db.
    Francois

  11. #11
    Star Lounger
    Join Date
    Oct 2006
    Location
    Albany, New York, USA
    Posts
    72
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Strange results in report (Access 2007)

    Repaired db then re- installed Access, Now it works (???). Not sure exactly what fixed it or what happened to cause the problem.
    Thanks all for your support.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •