Results 1 to 7 of 7
  1. #1
    3 Star Lounger siflaar's Avatar
    Join Date
    Jan 2001
    Location
    Amersfoort, Netherlands
    Posts
    203
    Thanks
    4
    Thanked 0 Times in 0 Posts

    problem with commandbutton names (Word 2003)

    Hello All,
    I created a Word document with fields, sections and command buttons. Every section is protected / blocked except the section that the user has to work in.
    After the user has filled the fields and text areas he/she presses the command button of that section. The section is signed with his/her login name and the date, the section is protected and the next section is unprotected, the document is saved and send via e-mail to the next person to work in his/her section.
    This al works very well.
    I named the command buttons: cmdPartA, cmdPartB etc.

    And now the strange thing:
    I have to change some text in the document. So I open the document, unprotect it and change the text. Then the document is protected again and is saved with a new name.
    When I open this new document all seems okay, but after a few seconds a message is shown:
    "Kan de ontwerpmodus niet afsluiten omdat besturingselement cmdPart011 niet kan worden gemaakt"
    (Sorry it is a Dutch text, translated it is something like: "can't exit design mode because control cmdPart011 can't be created "

    The strange effect is that al the names of my command buttons have been changed: cmdPartA11, cmdPartB11, etc.
    The only way to get rid of this problem is to recreate the document from scratch.

    I hope someone has a solution for me.

    Thanks in advance for your answer.
    Greetings,

    Patrick Schouten
    (The Netherlands)

  2. #2
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: problem with commandbutton names (Word 2003)

    Do you create the command buttons in code? If so, could you post the code?

  3. #3
    3 Star Lounger siflaar's Avatar
    Join Date
    Jan 2001
    Location
    Amersfoort, Netherlands
    Posts
    203
    Thanks
    4
    Thanked 0 Times in 0 Posts

    Re: problem with commandbutton names (Word 2003)

    Hello Hans,

    No, I create to buttons by hand in the document and than change the properties to give them a proper name.
    Greetings,

    Patrick Schouten
    (The Netherlands)

  4. #4
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: problem with commandbutton names (Word 2003)

    (For others reading this: Patrick sent me a sample document by e-mail)

    Hi Patrick,

    I have tried to reproduce the problem that you described but I haven't been able to do so in Word 2002 SP3.
    I unprotected the document, edited some text, then protected it for forms again, but the command buttons kept their original names and they still worked as intended (I tested each of them, after modifying the code so that the e-mails weren't actually sent). The document was saved in between. Closing and reopening the document, and quitting and restarting Word made no difference.

    So I'm afraid I have no idea what causes the problem for you, or how to solve it. <img src=/S/sorry.gif border=0 alt=sorry width=15 height=15>

  5. #5
    3 Star Lounger siflaar's Avatar
    Join Date
    Jan 2001
    Location
    Amersfoort, Netherlands
    Posts
    203
    Thanks
    4
    Thanked 0 Times in 0 Posts

    Re: problem with commandbutton names (Word 2003)

    Hans,

    Thanks for the effort.
    My conclusion is that this seems to be a local problem. So I will take it up with our IT department.
    Thanks
    Greetings,

    Patrick Schouten
    (The Netherlands)

  6. #6
    Silver Lounger
    Join Date
    Jul 2001
    Location
    Ottawa, Ontario, Canada
    Posts
    1,609
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: problem with commandbutton names (Word 2003)

    <P ID="edit" class=small>(Edited by wdwells on 13-Jan-09 08:08. On second reading, my usert's problem was not identical, but similar,)</P>Hi Patrick
    One of my users had a similar problem. The solution printed below solved it. This is adapted from Hans' post found <!post=here,749172>here<!/post> to address Office 11 instead of Office 12.


    - Quit all instances of Word.
    - Select Start | Run...
    - Type regedit and press Enter or click OK.
    - Navigate to HKEY_CURRENT_USERSoftwareMicrosoftOffice11.0WordDa ta.
    - Use File | Export to export the Data key to a .reg file.
    - With Data still selected, select Edit | Delete or press the Delete key.
    - Confirm that you want to delete this key and all subkeys.
    - Start Word again to see if the problem is gone.
    - If not, you can restore the Data key by opening the .reg file that you saved.

    H.T.H.
    Regards
    Don

  7. #7
    3 Star Lounger siflaar's Avatar
    Join Date
    Jan 2001
    Location
    Amersfoort, Netherlands
    Posts
    203
    Thanks
    4
    Thanked 0 Times in 0 Posts

    Re: problem with commandbutton names (Word 2003)

    Hello Don,

    Thanks for your reply.
    Unfortunately I am not able to check this because of restrictions our company sets on user accounts.
    But I will discuse this later on with out IT department.
    Greetings,

    Patrick Schouten
    (The Netherlands)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •