Page 1 of 2 12 LastLast
Results 1 to 15 of 16
  1. #1
    Star Lounger
    Join Date
    Dec 2000
    Posts
    82
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Opening Word Hidden Text Turned Off (Word XP)

    I'm creating a book with an extensive index and need to have Word open the hidden text turned off. No matter what I do, it insists on opening with the hidden text turned on. How can I make the default opening with hidden text turned off?

  2. #2
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Opening Word Hidden Text Turned Off (Word XP)

    You'd need a macro for that:
    - Open your document.
    - Press Alt+F11 to activate the Visual Basic Editor.
    - In the Project Explorer on the left hand side, double click the ThisDocument item for your document.
    - Copy/paste or type the following code into the module that appears:

    Private Sub Document_Open()
    ThisDocument.ActiveWindow.View.ShowHiddenText = False
    End Sub

    - Save the document.

    You'll have to make sure that macros are enabled when you open the document.

  3. #3
    Star Lounger
    Join Date
    Dec 2000
    Posts
    82
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Opening Word Hidden Text Turned Off (Word XP)

    Thanks for your help!! I did it, but it's not working. I use macros all the time, so I guess they're enabled properly. I don't have any other macros in the document. I normally keep the macros in the template. What should I do?

  4. #4
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Opening Word Hidden Text Turned Off (Word XP)

    Try changing the code to

    Private Sub Document_Open()
    ActiveDocument.ActiveWindow.View.ShowHiddenText = False
    End Sub

    And make sure that it is in the ThisDocument module of the template, not in a standard module.

  5. #5
    Star Lounger
    Join Date
    Dec 2000
    Posts
    82
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Opening Word Hidden Text Turned Off (Word XP)

    I'm still doing something wrong. I've put it in This Document of the template, save the project, save the document, exited the document. When I bring it back up, it's just the same.

    This is very important because I'll have clients opening the document and finding the index way off. (Of course, I'm delivering the print version, but I'm concerned that at some point someone will have access to the online version and have a disaster on their hands.)

  6. #6
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Opening Word Hidden Text Turned Off (Word XP)

    Could you create a copy of the template, remove all text from it, zip it and attach it to a reply?

  7. #7
    Star Lounger
    Join Date
    Dec 2000
    Posts
    82
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Opening Word Hidden Text Turned Off (Word XP)

    When I try to copy it, the macro in "This Document" doesn't show up. It's in the original template. Obviously, even though I've used MANY templates and studied everything I can find including Shana Kelly's wonderful explanation, I still don't understand templates vs. documents as they involve macros and other goodies.

    I've attached a copy of my template.

    I very, very much appreciate your help!
    Attached Files Attached Files

  8. #8
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts

    Re: Opening Word Hidden Text Turned Off (Word XP)

    You want to run code on someone else's machine? That might be blocked or might cause alarm. How about just deleting all the hidden text in copies you circulate to others? You could lock your fields so they don't change, and then use Find/Replace to remove all the text marked with Hidden Text formatting. (I haven't tested that, but it should be possible.)

  9. #9
    Star Lounger
    Join Date
    Dec 2000
    Posts
    82
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Opening Word Hidden Text Turned Off (Word XP)

    Are you telling me that this will work with hidden text marking index entries? What about a macro having to run on someone else's computer? Is this going to run on a client's computer? And why would hidden text be turned on by default? I think that's the big problem. Why can't I control it more easily? No one wants index markups shown all the time. That creates havock.

    Thanks once again.

  10. #10
    Star Lounger
    Join Date
    Dec 2000
    Posts
    82
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Opening Word Hidden Text Turned Off (Word XP)

    Well, I seem to be helpless. My system won't handle the zip file that you used. What do I need to do?

  11. #11
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Opening Word Hidden Text Turned Off (Word XP)

    Perhaps you don't need a macro at all.

    Index entries are visible, even if hidden text is not displayed, if the Show/Hide ¶ button is "on".
    To hide index entries, you must *not* display hidden text AND turn off the Show/Hide ¶ button.
    Word should remember these settings between sessions. They are user-level settings, however.

  12. #12
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Opening Word Hidden Text Turned Off (Word XP)

    Zip file replaced by HansV

    I suspect that you placed the code in the ThisDocument module of another template. I have added the code to the ThisDocument module in the template. I also added a Document_New event procedure so that hidden text will also disappear when the user creates a new document based on the template.

    Just for fun, I added some hidden text, and turned on the display of hidden text. When I create or open a document based on the template, I see the hidden text very briefly, then it disappears.
    Attached Files Attached Files

  13. #13
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Opening Word Hidden Text Turned Off (Word XP)

    Sorry, my bad. I forgot to turn off advanced compression in WinZip 12. I have corrected this and replaced the attachment.

    However, I now think you may not need code - see my other recent reply.

  14. #14
    Star Lounger
    Join Date
    Dec 2000
    Posts
    82
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Opening Word Hidden Text Turned Off (Word XP)

    That has been my thinking. I THOUGHT I had always been able to save it the way I wanted the hidden text or show all to be and it would return that way when I opened, but no more. In this file, I uncheck hidden text and show all. I save. I close. When I open again, hidden text is checked.

    Do you think there's another place where I've checked the wrong thing?

  15. #15
    Star Lounger
    Join Date
    Dec 2000
    Posts
    82
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Opening Word Hidden Text Turned Off (Word XP)

    I've attached a picture of my Tools/View check box.

    I've got to run out for a few minutes, but if you see anything dumb I've done, I'd LOVE to hear about it.

    Thanks.
    Attached Images Attached Images

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •