Results 1 to 3 of 3
  1. #1
    2 Star Lounger
    Join Date
    Mar 2004
    Location
    Christchurch
    Posts
    111
    Thanks
    0
    Thanked 0 Times in 0 Posts

    sub report height - blank (2002)

    I have a report with 5 sub-reports in the detail section. I have no report or page headers in the parent report, the header being a few fields from the "1" side of the "1 to many" side of the relationship. Each sub-report has "can grow" and "can shrink" set to yes. The amount of data populating each sub-report varies somewhat, therefore the height taken by the it as it grows varies. The issue I am seeking assistance with is that frequently the detail section will start on a new page, with the previous page having the few header fields on the top couple of centimeters of the page, the rest of that page being blank. I have not been able to discover how to adjust the sub-report height or the height of the detail section, or the various "force new page" or "keep together" options correctly to eliminate this blank space after the header fields. It even seems that in some cases the height of the sub-report is significantly shorter than the available height in the detail section, making it surprising that it insists on starting on the next page. The issue always is related to the first sub-report and the header sections, it is not replicated between any subsequent pairs of sub-reports.

    Any pointers on how to solve this would be gladly achieved.

  2. #2
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: sub report height - blank (2002)

    Have you also looked at the Keep Together property of the grouping levels in the Sorting and Grouping window?

    If you can't solve the problem, could you post a stripped down copy of your database? See <post#=401925>post 401925</post#> for instructions.

  3. #3
    2 Star Lounger
    Join Date
    Mar 2004
    Location
    Christchurch
    Posts
    111
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: sub report height - blank (2002)

    Sorry for the delay replying, yes I have set the Keep Together property to no avail. Time constraints and a pending holiday for a few weeks have meant I have not had an opportunity to anonymise the data and send a copy of the relevant objects for further examination, I will come back to this in March.

    Thanks - and regards
    Roger

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •