Results 1 to 3 of 3
  1. #1
    Lounger
    Join Date
    Mar 2005
    Posts
    27
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Formatting numbers in EU style (2003, SP3)

    Hello,
    I have kind of an odd question. I am based in the US and need to prepare a weekly report that will be used in the EU. I have been asked that the number format needs to follow EU guidelines (periods in place of commas). Now, if I were to send them a spreadsheet, the local computer settings would take care of this. However, I need to prepare the report and deliver as a PDF document, which means I need to set up the number format here in the US. The hard way is to change the settings in my local excel every time I prepare this report and then remember to change back when I am done. Is there an easier way? Could I use a custom number to format. I found this #"."##0_);(#"."##0);-_) which seems to take care of numbers below 1 million but does not work beyond that. Any help would be appreciated.
    Thanks,
    Altin

  2. #2
    3 Star Lounger
    Join Date
    Nov 2002
    Location
    New York, New York, USA
    Posts
    266
    Thanks
    0
    Thanked 19 Times in 19 Posts

    Re: Formatting numbers in EU style (2003, SP3)

    My suggestion is to use put the VBA Code below in your personal.xls workbook. The add a custom button to a Toolbar and attach the procedure to the button.
    Then by just hitting the botton you can change from one method to another.

    Sub MySeparator()

    If Application.DecimalSeparator = "," Then
    Application.DecimalSeparator = "."
    Application.ThousandsSeparator = ","
    Else
    Application.DecimalSeparator = ","
    Application.ThousandsSeparator = "."
    End If
    End Sub

    Regards,

    Tom Duthie

  3. #3
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Formatting numbers in EU style (2003, SP3)

    You can temporarily switch quite easily:
    - Select Tools | Options...
    - Activate the International tab.
    - Clear the check box "Use system separators".
    - Enter a comma in the Decimal separator box, and a period in the Thousands separator box.
    - Click OK.

    When you're done, simply tick the check box "Use system separators" again.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •