Results 1 to 14 of 14
  1. #1
    Silver Lounger
    Join Date
    Jun 2001
    Location
    Niagara Falls, New York, USA
    Posts
    1,878
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Access 2007 Opening FE.mdb the first time? (A2007 (12.0.6334.5000) SP1 Jet 4.0 SP-8)

    I’m New to Access 2007

    I develop FE.mdb apps in a2k and both FE.mdb and BE.mdb are in Access 2000 format

    I have a user that is getting a new computer with A2007 pre-installed.

    When I open the FE.mdb the first time it takes 7 minutes to open
    When I open the FE.mdb thereafter if only takes 20 seconds which is tipically normal

    What is happening during the first opening of the FE.mdb?

    Thanks, John

  2. #2
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Access 2007 Opening FE.mdb the first time? (A2007 (12.0.6334.5000) SP1

    Does that happen only once, or does the cycle repeat itself after rebooting the PC?

  3. #3
    Silver Lounger
    Join Date
    Jun 2001
    Location
    Niagara Falls, New York, USA
    Posts
    1,878
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Access 2007 Opening FE.mdb the first time? (A2007 (12.0.6334.5000) SP1

    It happens only once, after a reboot, it opens normally in 15-20 seconds

    I only have Access 2007 installed on the computer in question, however the symptom is similar to the following:

    http://support.microsoft.com/kb/942378

    · Access 2007 takes several minutes to repair itself

    You install Access 2007 and Access 2003 on the same computer. When you run Access 2007 after you run Access 2003, Access 2007 takes several minutes to repair itself.
    · You can still update the AutoNumber field data after you run an update query that sets an AutoNumber field to Null

    Any thoughts?

    John

  4. #4
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Access 2007 Opening FE.mdb the first time? (A2007 (12.0.6334.5000) SP1

    I take it that you have still have Access 2003 installed, so I'd suggest that you use Access 2003.

    If your user's new PC has only Access 2007, not 2003, he or she shouldn't have this problem.

  5. #5
    Silver Lounger
    Join Date
    Jun 2001
    Location
    Niagara Falls, New York, USA
    Posts
    1,878
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Access 2007 Opening FE.mdb the first time? (A2007 (12.0.6334.5000) SP1

    After further analysis, I put MsgBox in the On Open of my start-up form and it takes 7 minutes to get to the message box, then another 15 seconds to run all my start-up code and to my opening form which is normal

    How can I further trouble soot this?

    Thanks, John

  6. #6
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Access 2007 Opening FE.mdb the first time? (A2007 (12.0.6334.5000) SP1

    Is that in Access 2003 or 2007?

  7. #7
    Silver Lounger
    Join Date
    Jun 2001
    Location
    Niagara Falls, New York, USA
    Posts
    1,878
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Access 2007 Opening FE.mdb the first time? (A2007 (12.0.6334.5000) SP1

    Access 2007, I'm not using 2003, using 2000 for development

    To recap:

    1. When I open the Access 2000 FE.mdb the first time with Access 2007 it taks 7 minutes to open

    2. When I open the same Access 2000 FE.mdb a second and subsequent times thereafter with Access 2007 if only takes 20 seconds which is normal

    There are no error messages and the application seems to work OK.

    After further analysis, repeating step 1, I put a MsgBox in the On Open of my start-up form and it takes 7 minutes to get to the message box, then another 15 seconds to run all my start-up code and to my opening form which is normal

    What is happening during the first opening of the FE.mdb?

    Hope this maks sense

    John

  8. #8
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Access 2007 Opening FE.mdb the first time? (A2007 (12.0.6334.5000) SP1

    You've answered your own question higher up in this thread. If you want to avoid it, stick with one version of Access and never open the other version again.

  9. #9
    Silver Lounger
    Join Date
    Jun 2001
    Location
    Niagara Falls, New York, USA
    Posts
    1,878
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Access 2007 Opening FE.mdb the first time? (A2007 (12.0.6334.5000) SP1

    Access 2007 Opening Access 2000 mdb For The First Time?

    When a compiled, compacted Access 2000 FE.mdb is opened with Access 2007 for the first what happens exactly?

    Does it get converted to a 2007 format? Are there any websites available that describes what happens in this process?

    Thanks, John

  10. #10
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Access 2007 Opening FE.mdb the first time? (A2007 (12.0.6334.5000) SP1

    No, the database does *not* get converted to Access 2007 format. But I assume that Access has to update the references in the database's VBA project, and this probably means that all code has to be compiled again. And if you ran an earlier version of Access before running Access 2007, Access 2007 has to reinstall itself partially.

  11. #11
    Silver Lounger
    Join Date
    Jun 2001
    Location
    Niagara Falls, New York, USA
    Posts
    1,878
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Access 2007 Opening FE.mdb the first time? (A2007 (12.0.6334.5000) SP1

    That make sense

    In my case the the compile is not automatic, I have to manually compile after opening in a2k7, Is this normal?

    Thanks for you help,

    John

  12. #12
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Access 2007 Opening FE.mdb the first time? (A2007 (12.0.6334.5000) SP1

    When you open the database in Access 2007 for the first time, the code will probably only be marked as "to be compiled next time it is run", it will not be recompiled immediately.

  13. #13
    Silver Lounger
    Join Date
    Jun 2001
    Location
    Niagara Falls, New York, USA
    Posts
    1,878
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Access 2007 Opening FE.mdb the first time? (A2007 (12.0.6334.5000) SP1

    Additional information to supplement HansV response:

    Is it safe to run Access 2003 and 2007 at the same time?

    http://stackoverflow.com/questions/156694/...t-the-same-time

  14. #14
    4 Star Lounger
    Join Date
    Feb 2001
    Location
    Richland, Washington, USA
    Posts
    407
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Access 2007 Opening FE.mdb the first time? (A2007 (12.0.6334.5000) SP1

    John,

    Sounds like this has already been beat to death, but a few comments nonetheless (no magic solutions, though):

    If you are going back and forth between Access 2007 and prior versions on the same machine, the delay you are observing is not surprising at all (for reasons Hans has mentioned) -- I didn't know you could even have them on the same machine. If you have Access 2003 (or 2000) on one machine and ONLY Access 2007 on another and you bring over your database (FE only presumably; BE out on a shared drive somewhere?) to the Access 2007 machine and you get the 7 minute start-up, this is indeed "curious" (as you obviously are). Do you observe the same delay if you do this with a self-contained (no BE) database (i.e., could it have something to do with establishing the links with the back end)?

    When I first installed Office 2007 a month or so ago, all of my Access 2003 databases started up pretty much seamlessly with no notable delays. However, I have very few that are in a FE-BE configuration. One that is a "commercial-quality" FE-BE application, with the BE on a server and about 60 users (some 2003, some 2007) loaded without any unusual delay that I can remember.

    Certainly a way to avoid the problem is to stay with 2003 or 2000, but this doesn't answer the curiosity question -- why's Access 2007 struggling the first time it's opening your Access 2000 database?

    Hope this helps, a little anyway.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •