Results 1 to 3 of 3
  1. #1
    5 Star Lounger
    Join Date
    Mar 2001
    Location
    New York, NY
    Posts
    922
    Thanks
    2
    Thanked 12 Times in 11 Posts

    Errors with Template (2007)

    I've worked on 20 or 25 Word 2007 templates, all global templates, and most of them with 6 or 8 user forms and 3 or 4 code modules. Many have references other templates or DLLs.

    In the last couple of days, I've been working on a very simple template: 2 user forms, two code modules, no references. When I attempted to save yesterday, a "catastrophic error" displayed, and I was unable to export the user forms or modules. I went back to an earlier version. I've worked on that, adding a new user form, and when I attempted to save, the error was "file permission error". I was able to export the user forms and code modules and import them into a new container template.

    I am always careful to unload a startup template before opening it for modification. (I do leave it in the Startup folder.) Two things that I've done that I don't typically do: 1.0 I created shortcut keys to access two macros for demo purposes, since I haven't started to develope the ribbon for this template. 2.) I've worked on this template in the office and at home. The office has SP! of Office 2007; at home I have not applied SP1.

    Can anyone offer a clue as to why these errors are occuring? Does either the shortcut key or SP sound like a cause for trouble?

    Thanks,
    Richard

  2. #2
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Errors with Template (2007)

    I don't think either the shortcut keys or the service pack would cause this; it's probably one of those random glitches - a bit fell over in an important location or so. When something like that happens, it's best to reboot your PC to get rid of any memory corruption.

  3. #3
    5 Star Lounger
    Join Date
    Mar 2001
    Location
    New York, NY
    Posts
    922
    Thanks
    2
    Thanked 12 Times in 11 Posts

    Re: Errors with Template (2007)

    I Google'd the error, and I found a number of posts in forums reporting a similar problem. It typically involves a stand-alone home PC and a networked office PC, with transfer done with a USB device.

    Despite this, I think you're probably correct that this is a random glitch.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •