Results 1 to 4 of 4
  1. #1
    New Lounger
    Join Date
    Mar 2009
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I am using Office 03 and doing a mail merge from Excel to Word. When my numbers show up on word I dont have any commas. For example it shows up as 4550 instead of 4,550..... What do I have to do to get commas?

  2. #2
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts
    [quote name='dcorp' post='765961' date='18-Mar-2009 05:32']I am using Office 03 and doing a mail merge from Excel to Word. When my numbers show up on word I dont have any commas. For example it shows up as 4550 instead of 4,550..... What do I have to do to get commas?[/quote]
    Welcome to theLounge!

    One option is to add a format switch to the date mailmerge field in Word:
    - Right-click the merge field.
    - Select Toggle Field Codes from the popup menu.
    - Insert the following before the closing brace } but after the merge field name.

    \# "#,##0"

    - Press F9 to hide the field code and to update the field.

    Another method:
    - In Word, select Tools | Options...
    - Activate the General tab.
    - Tick the "Confirm conversion at Open" check box.
    - Click OK.
    - Go back to step 3 of the mail merge wizard (task pane).
    - Click "Select a different list".
    - Locate your workbook again.
    - This time, you'll be prompted for a method to connect to the workbook.
    - Select "MS Excel worksheets via DDE (*.xls)", then click OK.
    - Continue as usual.
    The mail merge should now preserve the formatting from Excel.

  3. #3
    Super Moderator
    Join Date
    May 2002
    Location
    Canberra, Australian Capital Territory, Australia
    Posts
    5,054
    Thanks
    2
    Thanked 417 Times in 346 Posts
    [quote name='HansV' post='765978' date='18-Mar-2009 17:49']Welcome to theLounge!

    One option is to add a format switch to the date mailmerge field in Word:
    - Right-click the merge field.
    - Select Toggle Field Codes from the popup menu.
    - Insert the following before the closing brace } but after the merge field name.

    \# "#,##0"

    - Press F9 to hide the field code and to update the field.[/quote]
    Hi Hans,

    Using:
    \# "#,##0"
    forces the output to pad the result with spaces if there are less than 4 digits. This usually isn't wanted, so it's generally better to use:
    \# ",0"
    Cheers,

    Paul Edstein
    [MS MVP - Word]

  4. #4
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts
    [quote name='macropod' post='766151' date='19-Mar-2009 06:56']Hi Hans,

    Using:
    \# "#,##0"
    forces the output to pad the result with spaces if there are less than 4 digits. This usually isn't wanted, so it's generally better to use:
    \# ",0"[/quote]
    Thanks!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •