Results 1 to 5 of 5
  1. #1
    New Lounger
    Join Date
    Mar 2009
    Posts
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I have a large Word document that includes a long table. Part of the table holds 82 JPEGs I have included with Insert->Picture. Yesterday the pictures disappeared and were replaced by small square markers with an X inside, in the upper left hand corner where the picture used to be. I can select a picture and see its outline, but it no longer displays or prints. Has anyone seen this before? How do I fix it?

  2. #2
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts
    [quote name='bgreen' post='766916' date='23-Mar-2009 15:12']I have a large Word document that includes a long table. Part of the table holds 82 JPEGs I have included with Insert->Picture. Yesterday the pictures disappeared and were replaced by small square markers with an X inside, in the upper left hand corner where the picture used to be. I can select a picture and see its outline, but it no longer displays or prints. Has anyone seen this before? How do I fix it?[/quote]
    If you select one of the pictures and press Shift+F9, does it change to an INCLUDEPICTURE field code? If so, Word may have changed the paths after you saved the document. If the paths are "relative" paths, you may need to resave the document (File>SaveAs) into the folder that makes the relative links correct, and then update the links (Ctrl+A, F9).

    If you do not get a field code, have you tried the document on another PC in case your PC has a memory or graphics problem?

  3. #3
    New Lounger
    Join Date
    Mar 2009
    Posts
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts
    [quote name='jscher2000' post='766918' date='23-Mar-2009 18:19']If you select one of the pictures and press Shift+F9, does it change to an INCLUDEPICTURE field code? If so, Word may have changed the paths after you saved the document. If the paths are "relative" paths, you may need to resave the document (File>SaveAs) into the folder that makes the relative links correct, and then update the links (Ctrl+A, F9).

    If you do not get a field code, have you tried the document on another PC in case your PC has a memory or graphics problem?[/quote]

    -----------------------------

    Yes, I get an INCLUDEPICTURE field code. Does this mean I added the picture using a link? I thought I remembered adding these pictures as embedded.

    Anyway, I did the resave and then updated the links but got an error saying the relink failed. I notice that the field code links point to the wrong directory. I'm not sure how this happened but it did. So I'm guessing I have to relink all 82 of these JPEGs. Is that correct?

    Is it likely I did something wrong here, or am I another victim of a Word quirk?

  4. #4
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts
    Quote Originally Posted by bgreen' post='766940 View Post
    Anyway, I did the resave and then updated the links but got an error saying the relink failed. I notice that the field code links point to the wrong directory. I'm not sure how this happened but it did. So I'm guessing I have to relink all 82 of these JPEGs. Is that correct?
    Try closing the document and re-opening it. That might be the step that triggers Word rewriting those relative URLs. However, if you can't get the document into the "correct" folder, you might be able to fix the paths using Find and Replace. First display all of the field codes using Alt+F9, and then run the Find and Replace. Note that you may need to double the \\ in the path. Please check the help for INCLUDEPICTURE, as I cannot remember when it is necessary.

    Once the links are working again, you can unlink the pictures (in other words, convert them to embedded pictures) using Ctrl+Shift+F9.

  5. #5
    New Lounger
    Join Date
    Mar 2009
    Posts
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts
    [quote name='jscher2000' post='766950' date='23-Mar-2009 20:21']I think the usual default is to embed them, but perhaps this is a selectable option?


    Try closing the document and re-opening it. That might be the step that triggers Word rewriting those relative URLs. However, if you can't get the document into the "correct" folder, you might be able to fix the paths using Find and Replace. First display all of the field codes using Alt+F9, and then run the Find and Replace. Note that you may need to double the \\ in the path. Please check the help for INCLUDEPICTURE, as I cannot remember when it is necessary.

    Once the links are working again, you can unlink the pictures (in other words, convert them to embedded pictures) using Ctrl+Shift+F9.[/quote]

    I used Find and Replace to reset all of the Field Code paths to the correct folder. My problem is fixed but its a mystery as to what caused it.

    Thank you. I could never have fixed this without your help.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •