Results 1 to 5 of 5
  1. #1
    5 Star Lounger
    Join Date
    Aug 2006
    Posts
    784
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hello,

    Whenever I cut and copy Times New Roman text from one part of my document and paste it into my a Table, the text takes on the Garamond font. The table grid style does not use that font, but rather, Times New Roman. When I cut the text that I later paste, I and not cutting the paragraph sign at the end of the text. After I paste the text into the table, I select and press ctrl + spacebar, but that does not change the font back to Times New Roman as it should. I must manually type “Times New Roman” into the font box on the toolbar. The document otherwise behaves normally.

    Does anyone know what is happening and how to stop it?

    Regards,

    JMT

  2. #2
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts
    [quote name='jmt356' post='767653' date='26-Mar-2009 12:20']Whenever I cut and copy Times New Roman text from one part of my document and paste it into my a Table, the text takes on the Garamond font.[/quote]
    What is the normal font in the document? Can you post a stripped down version for examination?

  3. #3
    Super Moderator
    Join Date
    Jan 2001
    Location
    Melbourne, Victoria, Australia
    Posts
    3,853
    Thanks
    4
    Thanked 259 Times in 239 Posts
    [quote name='jmt356' post='767653' date='27-Mar-2009 06:20']Whenever I cut and copy Times New Roman text from one part of my document and paste it into my a Table, the text takes on the Garamond font. The table grid style does not use that font, but rather, Times New Roman. When I cut the text that I later paste, I and not cutting the paragraph sign at the end of the text. After I paste the text into the table, I select and press ctrl + spacebar, but that does not change the font back to Times New Roman as it should.[/quote]
    It will probably be easiest to work this out by seeing the actual document but the things I would check first are:
    1. The name of the table style - are you positive it is "Table Grid"?
    2. The style name and definition for the paragraph where you are pasting the text
    3. The font applied at the insertion point when you paste (although this shouldn't have an effect)
    If none of those reveal anything then the next thing to do is check the style settings for the table style being used AND the cell you are pasting into. The table styles allow you to define font for a huge range of cells including:
    • all cells
    • top left cell
    • top right cell
    • heading row(s)
    • first column
    • last column
    • last row
    • alternate rows
    • alternate columns

    so it is not as easy to diagnose the problem without examining every one of those possibilities for a font override.
    Andrew Lockton, Chrysalis Design, Melbourne Australia

  4. #4
    5 Star Lounger
    Join Date
    Aug 2006
    Posts
    784
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Unfortunately, the problem is not happening in teh stripped down version of the document. I think it only happens in certain graphs. Let me see the next time it happens which graphs it is happening in and then I will see if I can post a document with only those graphs.

    Jefferson: the normal font in the document is Times New Roman 11.

    Andrew:
    1. The name of the style of the text in the tables is definitely Table Grid. This can be changed to Body Text if I press "ctrl + shift + x" but I can't seem to get it to normal, even if I press "ctrl + shift + N," because the name of the style remains "Table Grid." I can get the name to change to Body Text if I press "ctrl + shift + x," but can't get it to change to "Normal," even if I manually type "Normal" in the Style box. But this is not so significant, since Table Grid, like Normal, is Times New Roman 11, which doesn't bother me any.
    2. In the tables where the problem occurs, the problem occurs regardless of the style of the text that I am cutting and pasting. If I cut from Normal text, it appears as Garamond; if I cut from Body Text, it appears as Garamond.
    3. I think in the tables where the problem occurs, the text where the cursor is when I paste the other text has the style name of "Normal + ..." with some settings I can't remember now. I'm sorry to be so vague, but I can't seem to localize the problem right now bc the document that is causing it is very long with many many tables. But I will post again when I find it.

    Regards,

    JMT

  5. #5
    Super Moderator
    Join Date
    Jan 2001
    Location
    Melbourne, Victoria, Australia
    Posts
    3,853
    Thanks
    4
    Thanked 259 Times in 239 Posts
    [quote name='jmt356' post='767961' date='29-Mar-2009 01:09']1. The name of the style of the text in the tables is definitely Table Grid. This can be changed to Body Text if I press "ctrl + shift + x" but I can't seem to get it to normal, even if I press "ctrl + shift + N," because the name of the style remains "Table Grid." I can get the name to change to Body Text if I press "ctrl + shift + x," but can't get it to change to "Normal," even if I manually type "Normal" in the Style box. But this is not so significant, since Table Grid, like Normal, is Times New Roman 11, which doesn't bother me any.
    2. In the tables where the problem occurs, the problem occurs regardless of the style of the text that I am cutting and pasting. If I cut from Normal text, it appears as Garamond; if I cut from Body Text, it appears as Garamond.[/quote]
    Table Grid is a table style which can be set to override the paragraph styles of Normal or Body Text. Table styles are odd in that when the paragraph is set to Normal style, you see the name of the Table style rather than the name of the Paragraph style. You can also see the name of the current table style by putting your cursor at the end of a table row (outside the right hand side of the table). Another oddity of table styles is that they can be customised to override the paragraph style attributes - this can be a good thing if you don't use paragraph styles but is generally a bad thing for you since you do use paragraph styles.

    It sounds like your table style "Table Grid" has font settings in it that are causing this override. If you try changing the table style to "Table Normal" you may find that the font override hasn't been set for that style. You might also try editing the Table Grid style directly or re-importing the Table Grid style from another document that doesn't suffer the same problem.
    Andrew Lockton, Chrysalis Design, Melbourne Australia

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •