Results 1 to 2 of 2
  1. #1
    Super Moderator
    Join Date
    Jun 2002
    Location
    Mt Macedon, Victoria, Australia
    Posts
    3,993
    Thanks
    1
    Thanked 45 Times in 44 Posts
    I am having an issue with several databases with Access 2007 (with the database in 2000 format).
    In the footer of a subform I sum a column of figures using =sum([fieldname]), and hide this control, then transfer the total to the Main form, by having a control on the Main Form whose control source is =subformname.Form!controlname.

    You see something like this.
    [attachment=83154:subform1.gif]

    In 2007 what happens sometimes is that I see 'calculating' in the status bar, and the total never appears. If I unhide the subform total it remains blank.
    However the moment I move the focus away from Access, the totals all fill in!
    [attachment=83155:subform2.gif]

    • The same databases do not display this behaviour in 2003
    • I have compacted, repaired, imported all objects to a new db, and even converted to accdb format.
    • I imported the linked tables to see what happens - no difference.
    • MSKB article 927152 deals with a similar issue, but does not offer a solution. In my cases the subform is only filtered by the master child fields.


    Has anyone else encountered this issue?
    Attached Images Attached Images
    Regards
    John



  2. #2
    Gold Lounger
    Join Date
    Feb 2001
    Location
    Sint Niklaas, Belgium
    Posts
    2,778
    Thanks
    0
    Thanked 0 Times in 0 Posts
    [quote name='johnhutchison' post='768390' date='31-Mar-2009 05:09'][/quote]
    I've never seen this (yet).
    Francois

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •