Results 1 to 3 of 3
  1. #1
    New Lounger
    Join Date
    Mar 2008
    Location
    New York, New York, USA
    Posts
    19
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I have a set of documents where random paragraphs somehow have been marked "Do not check spelling or grammar".

    I want to write a macro to reset this, which seems simple enough:
    Application.ResetIgnoreAll
    ActiveDocument.SpellingChecked = False
    ActiveDocument.GrammarChecked = False

    However, the macro doesn't change the setting.

    The only way I can seem to reset this is to select the individual paragraphs and uncheck the the option under the "Check Language" dialog. I haven't tried a macro that will run through all the paragraphs, because it seems like overkill. But maybe it can't be avoided.

    Any idea if there's a way to just reset the option for the entire document at once?

    Many thanks!
    John

  2. #2
    Plutonium Lounger
    Join Date
    Nov 2001
    Posts
    10,550
    Thanks
    0
    Thanked 7 Times in 7 Posts
    Try
    ActiveDocument.Content.NoProofing = False

  3. #3
    New Lounger
    Join Date
    Mar 2008
    Location
    New York, New York, USA
    Posts
    19
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Post

    Thank you! That seems to work!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •