Results 1 to 5 of 5
  1. #1
    3 Star Lounger
    Join Date
    Feb 2009
    Posts
    308
    Thanks
    0
    Thanked 1 Time in 1 Post
    When I put a check in Page break before (Paragraph>Line and Page Break>Pagination) a section in a report, Word 2007 applies this same page break to all sections of a report that use this same Heading style, frocing me to press Ctrl+Z to undo the macro change. If I understand it correctly, Word is set by default to apply this change at a macro level to all sections with this same heading style. Is there a Word setting I can adjust to undo this? 99% of the time, it's more distracting or annoying than helpful. Thanks.

  2. #2
    WS Lounge VIP
    Join Date
    Mar 2006
    Location
    Maryland, USA
    Posts
    690
    Thanks
    17
    Thanked 66 Times in 56 Posts
    [quote name='ben000' post='769898' date='09-Apr-2009 17:01']When I put a check in Page break before (Paragraph>Line and Page Break>Pagination) a section in a report, Word 2007 applies this same page break to all sections of a report that use this same Heading style, frocing me to press Ctrl+Z to undo the macro change. If I understand it correctly, Word is set by default to apply this change at a macro level to all sections with this same heading style. Is there a Word setting I can adjust to undo this? 99% of the time, it's more distracting or annoying than helpful. Thanks.[/quote]
    Word 2007 and every previous version will do this if your style is set for automatically update. Note that this hasn't been the default for Word since at least W2000.
    Pam Caswell

  3. #3
    3 Star Lounger
    Join Date
    Feb 2009
    Posts
    308
    Thanks
    0
    Thanked 1 Time in 1 Post
    Ahh. Thanks. What specific setting do I need to adjust?

  4. #4
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts
    For all styles except the Normal style, there's a check box labeled "Automatically update" in the Modify Style dialog. Make sure that this check box is clear (not ticked).

    For the Normal style, you need to use VBA:
    - Press Alt+F11 to activate the Visual Basic Editor.
    - Press Ctrl+G to activate the Immediate window.
    - Type the following line (or copy/paste it) and press Enter:

    ActiveDocument.Styles(wdStyleNormal).Automatically Update = False

  5. #5
    3 Star Lounger
    Join Date
    Feb 2009
    Posts
    308
    Thanks
    0
    Thanked 1 Time in 1 Post
    Thanks.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •