Results 1 to 9 of 9
  1. #1
    Lounger
    Join Date
    Oct 2007
    Location
    West Virginia, USA
    Posts
    33
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I had 4 Windows XP Pro computers networked and working perfectly. Then we moved them to a new building, and put in new co-ax from the satellite dish to the modem. Rehooked everything to the same wired router used before, and the internet works perfectly. But none of the computers recognize any of the others, so I can't share files or printers. In My Network Places, when I double click on Workgroup, it tells me I don't have permission and that it can't find the path. This happens on every computer.

    I made sure that Windows firewall is turned off, and that my Sunbelt Personal Firewall was configured correctly and hadn't lost any of the settings.

    Each computer can successfully ping the others using the IP address, but fail when using the computer names. Net view fails except on the computer being used with error 53.

    I've tried changing computer names, and re-running the Setup Network Wizard (although I've since been told that probably made things worse). Nothing works.

    Could someone please(!) help me?

    Thanks,
    Sheila

  2. #2
    Plutonium Lounger
    Join Date
    Nov 2001
    Posts
    10,550
    Thanks
    0
    Thanked 7 Times in 7 Posts
    This sounds like a DNS problem to me. Are your computers all configured to get their network settings from a DHCP server? Does any of them have a hard coded DNS address?

    Could you please try following the steps in Troubleshooting file shares on a home network and let us know what happens.

  3. #3
    Lounger
    Join Date
    Oct 2007
    Location
    West Virginia, USA
    Posts
    33
    Thanks
    0
    Thanked 0 Times in 0 Posts
    [quote name='StuartR' post='772112' date='24-Apr-2009 06:17']This sounds like a DNS problem to me. Are your computers all configured to get their network settings from a DHCP server? Does any of them have a hard coded DNS address?

    The addresses are assigned by DHCP on all computers. But on this computer, I saw the following error in the system log:
    Your computer was not able to renew its address from the network (from the DHCP Server) for the Network Card with network address 00044B159A00. The following error occurred:
    The semaphore timeout period has expired. . Your computer will continue to try and obtain an address on its own from the network address (DHCP) server.

    I did not see this error in the log of the other computer. (Although there are 5 computers on the network, I am only working with 2 of them until I get the problem solved. They all have the same problem.)

    As far as I know, they don't have a hard coded DNS address. (But where do I look to make sure?)


    Could you please try following the steps in Troubleshooting file shares on a home network and let us know what happens.[/quote]


    PHYSICAL CONNECTIVITY:
    I'm using a D-Link (DI-604) router, a satellite dish and modem. This computer has ethernet cable connected from modem to router, from router to an APC surge protector, from the surge protector to the computer.
    For the other computer, the cable from the router goes to an APC UPS and then to the computer.

    All the PCs are connected by cable to the router in a similar way.

    On this computer, I see the green and orange lights on the network cards, and green light on the router. On the other computer, the lights are orange and a sort of yellow-green. (I can't tell if it is true green). The router lights are green for all the computers.

    FIREWALL:
    All the computers use Sunbelt's Personal Firewall (and also Vipre), and are configured according to Sunbelt's directions for networking. (This is the same configuration that worked perfectly before moving into the new building).

    Windows firewall is turned off on all the computers.

    As far as I can tell, previous firewalls have been completely removed (using Comodo registry cleaner to remove any registry entries that don't go anywhere).

    After turning off the firewalls: IP ADDRESSES:
    IP Address from xi-main: 192.168.0.101
    Gateway address: 192.168.0.1

    IP Address from ix-old:192.168.0.100
    Gateway address: 192.168.0.1

    Each PC connects to the internet with no problems.

    Each PC pings the gateway address successfully.

    Each PC pings the IP address of each computer successfully.

    Pinging by name fails for each computer trying to ping the other computer with error saying "Could not find host ..."

    USER ACCOUNTS:
    I created an identical guest account and password on each computer and logged in to each computer.

    OTHER DIAGNOSTICS:
    NET USE gave error 67 (network name cannot be found) when I tried it on each computer.

    NET VIEW of the other computer failed with error 53 on each computer.

    NET VIEW of itself was successful on each computer.

    In Manage\Open Shared Folders\Sessions, using the guest login, Access was Denied. Same for Shares. When I logged in as Administrator again, Sessions showed a connections from the other computer for each PC. Shares showed the shared files of the PC I was on.
    ---------------------------

    It does seem as if the problem has to do with the computer names not being able to be used correctly. Yesterday, while trying to figure out what was wrong, I changed the computer names of both computers, but it doesn't seem to have made any difference.

    What do you see from all this info? Anything helpful (I HOPE!)?

    Sheila

  4. #4
    Plutonium Lounger
    Join Date
    Nov 2001
    Posts
    10,550
    Thanks
    0
    Thanked 7 Times in 7 Posts
    Sheila,

    Yes, you don't seem to be able to use DNS to find your computers.

    Can you browse to sites on the Internet successfully? If so then presumably DNS is working for those, but just to check can you try typing the following commands from each computer.
    IPCONFIG /ALL
    (note there is a space before the / and no space after it)
    (look for the address of the DNS server and let us know what it is)

    NSLOOKUP
    (this should show the same DNS server address as above and leave you with a > prompt)

    www.microsoft.com
    (should give a valid address)

    www.wopr.com
    (should give 174.129.241.139)

    name of the other computer
    (should give the correct IP address)

    EXIT
    (should get you out of NSLOOKUP)

    Try shutting down and restarting your router, wait 2 minutes for it to finish restarting and then type the following command on each computer
    IPCONFIG /REGISTERDNS
    (note there is a space before the / but no space between / and REGISTERDNS)

    wait about 5 minutes and then try
    PING computername
    (where computername is the name of the other computer)

  5. #5
    Lounger
    Join Date
    Oct 2007
    Location
    West Virginia, USA
    Posts
    33
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Stuart,

    Answering you backwards after doing everything:

    3 of the 4 computers pinged each other successfully. The 4th (mine) says it could not find host (computername) for any of the other 3.

    All 4 of the computers browses the internet with no problems.

    IPCONFIG /ALL
    DNS server is 192.168.0.1 (This is the same address for Default Gateway and DHCP server)

    NSLOOKUP
    "Can't find server name for address 192.168.0.1: Non-existent domain. Default servers are not available. Default server: Unknown. Address: 192.168.0.1


    www.microsoft.com
    Server: UnKnown
    Address: 192.168.0.1
    Non-authoritative answer:
    Name: lb1.www.ms.akadns.net
    Addresses: 65.55.21.250, 65.55.12.249
    Aliases: www.microsoft.com, toggle.www.ms.akadns.net
    g.www.ms.akadns.net


    www.wopr.com
    Server: UnKnown
    Address: 192.168.0.1
    Non-authoritative answer:
    Name: www.wopr.com
    Address: 174.129.241.139


    xi-old
    Server: UnKnown
    Address: 192.168.0.1
    *** UnKnown can't find xi-old: Non-existent domain


    matcutter
    Server: UnKnown
    Address: 192.168.0.1
    *** UnKnown can't find matcutter: Non-existent domain


    bob-computer
    Server: UnKnown
    Address: 192.168.0.1
    *** UnKnown can't find bob-computer: Non-existent domain

    After shutting down and restarting the router and typing IPCONFIG REGISTERDNS: Results from this (my) computer.
    C:\WINDOWS\system32>ping xi-old
    Ping request could not find host xi-old. Please check the name and try again.

    C:\WINDOWS\system32>ping matcutter
    Ping request could not find host matcutter. Please check the name and try again.

    C:\WINDOWS\system32>ping bob-computer
    Ping request could not find host bob-computer. Please check the name and try aga
    in.

    Although the other 3 computers can now ping each other successfully, they still get the same results for NSLOOKUP (non-existent domain, etc)

    I'm guessing this all means that the problem is only with my computer and that is causing the others not to see it? (As well as it not seeing the others).

    Sheila




    [quote name='StuartR' post='772224' date='24-Apr-2009 22:40']Sheila,

    Yes, you don't seem to be able to use DNS to find your computers.

    Can you browse to sites on the Internet successfully? If so then presumably DNS is working for those, but just to check can you try typing the following commands from each computer.
    IPCONFIG /ALL
    (note there is a space before the / and no space after it)
    (look for the address of the DNS server and let us know what it is)

    NSLOOKUP
    (this should show the same DNS server address as above and leave you with a > prompt)

    www.microsoft.com
    (should give a valid address)

    www.wopr.com
    (should give 174.129.241.139)

    name of the other computer
    (should give the correct IP address)

    EXIT
    (should get you out of NSLOOKUP)

    Try shutting down and restarting your router, wait 2 minutes for it to finish restarting and then type the following command on each computer
    IPCONFIG /REGISTERDNS
    (note there is a space before the / but no space between / and REGISTERDNS)

    wait about 5 minutes and then try
    PING computername
    (where computername is the name of the other computer)[/quote]

  6. #6
    Plutonium Lounger
    Join Date
    Nov 2001
    Posts
    10,550
    Thanks
    0
    Thanked 7 Times in 7 Posts
    It seems to me that DNS is working fine, but that the computers on your local network are not being registered by the DNS server on your router.

    This should not matter if the computers are correctly configured to use h-node name resolution.

    To configure this you should modify the following registry key
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Servic es\NetBT\Parameters\DhcpNodeType

    Note the current value, and then change it to 0x00000008 for h-node

  7. #7
    Lounger
    Join Date
    Oct 2007
    Location
    West Virginia, USA
    Posts
    33
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Wow, Stuart, that fixed it!

    I am curious though - in Microsoft's article on on nodes, it says it applies to Windows NT, Windows 95. and Windows 3.11. It doesn't mention Windows XP. Since it obviously worked, is it because my router is so old?

    Also, it's possible the whole problem was because when we got all the computers moved, it was late and I was tired and I connected the cables to the router reversed from what it should have been. When the internet didn't work, I realized why and changed the cables and then the internet worked fine. I'm guessing that that reversal is what caused the problem. But now that it works, I am greatly relieved and overjoyed.

    I made the registry key change only on my computer. Should I also change the registry key on the other computers??

    Thanks!!!!
    Sheila


    [quote name='StuartR' post='772354' date='26-Apr-2009 14:36']It seems to me that DNS is working fine, but that the computers on your local network are not being registered by the DNS server on your router.

    This should not matter if the computers are correctly configured to use h-node name resolution.

    To configure this you should modify the following registry key
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Servic es\NetBT\Parameters\DhcpNodeType

    Note the current value, and then change it to 0x00000008 for h-node[/quote]

  8. #8
    Plutonium Lounger
    Join Date
    Nov 2001
    Posts
    10,550
    Thanks
    0
    Thanked 7 Times in 7 Posts
    [quote name='sheilacaim' post='772385' date='26-Apr-2009 20:47']I made the registry key change only on my computer. Should I also change the registry key on the other computers??[/quote]
    Yes.

    I don't know why this needed doing, the change we made set the parameter to its default value.

  9. #9
    Lounger
    Join Date
    Oct 2007
    Location
    West Virginia, USA
    Posts
    33
    Thanks
    0
    Thanked 0 Times in 0 Posts
    OK, I'll change the others.

    Thanks very, very much for your help!

    Sheila




    [quote name='StuartR' post='772410' date='26-Apr-2009 23:02']Yes.

    I don't know why this needed doing, the change we made set the parameter to its default value.[/quote]

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •