Results 1 to 10 of 10
  1. #1
    New Lounger
    Join Date
    Sep 2001
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Num Lock registry setting not persisting

    I saw the threads on the registry hack for enabling num lock on login. This has been bugging me for a while, so I tried it immediately. Unfortunately, after I change the InitialKeyboardIndicators setting to 2, per the post, when I log out and log back on, num lock does not go on, and the registry setting has reverted to 0 (When I run regedit again prior to logging off, the value remains 2). This seems to be a problem only on my primary work machine. Any ideas appreciated.

    Thanks,
    Arnie

  2. #2
    Plutonium Lounger Leif's Avatar
    Join Date
    Dec 2000
    Location
    U.K.
    Posts
    14,010
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Num Lock registry setting not persisting

    You did set
    HKEY_USERS.DEFAULTControl PanelKeyboardInitialKeyboardIndicators
    as well as for current user?

    There is also a setting in the Bios (F2 or Delete at boot-up) that may also need to be set.

  3. #3
    New Lounger
    Join Date
    Sep 2001
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Num Lock registry setting not persisting

    Leif, thanks for the response. I made sure the .default user was set to 2, as well as the current user. I also confirmed the BIOS NumLock setting was enabled. Same results: the current user value resets to 0 when I logoff/logon. The .default setting remains at 2. The num lock does not enable until I set it on with the NumLock key.

    Please advise if any ideas on other things to try, and thanks again for the assistance.
    Arnie

  4. #4
    Plutonium Lounger Leif's Avatar
    Join Date
    Dec 2000
    Location
    U.K.
    Posts
    14,010
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Num Lock registry setting not persisting

    The only other thing I can find is this tip at <A target="_blank" HREF=http://www.jsiinc.com/subf/tip2600/rh2628.htm>JSI</A>

  5. #5
    2 Star Lounger
    Join Date
    Dec 2000
    Location
    Texas
    Posts
    149
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Num Lock registry setting not persisting

    Make certain that numlock is 'on' when you logoff. The '2' is a memory setting, of the logoff state.

  6. #6
    New Lounger
    Join Date
    Sep 2001
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Num Lock registry setting not persisting

    Leif & Monique,
    Thanks. I saw the post about the script, and was hoping to avoid that, but maybe I'll have to try it. Also, numlock is on when logging off.

    If this is the biggest problem I have with my system, I'll consider myself fortunate.
    Arnie

  7. #7
    Plutonium Lounger Leif's Avatar
    Join Date
    Dec 2000
    Location
    U.K.
    Posts
    14,010
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Num Lock registry setting not persisting

    Just as a matter of interest, during boot-up, does the numlock indicator ever come on?
    (Mine flickers about then switches on for good at around the 'Loading settings' message point.)
    I was just wondering if there was something actively turning it OFF at log-on ?

  8. #8
    New Lounger
    Join Date
    Sep 2001
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Num Lock registry setting not persisting

    When restarting, numlock comes on immediately (at BIOS setup/POST time) and stays on until about 2/3 of the way through the first Starting Up Windows screen (before full graphics mode is enabled). It then goes out and stays out - no flickering noticed. By the time I get to Loading Settings, it has been dark for awhile. FYI, I am running W2K Advanced Server.

  9. #9
    Star Lounger
    Join Date
    Mar 2001
    Location
    CA, USA
    Posts
    53
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Num Lock registry setting not persisting

    I had this NUMLOCK situation too, and it seemed to correct itself after making the registry change per the Microsoft Support article at:
    http://support.microsoft.com/support/kb/ar...s/Q154/5/29.ASP

    Could you setting change be set via a Local Security Policy setting?

    If you login as a different user and adjust that registry setting to "2" and logoff and log back in as that different user does that setting stay or not?

    Lastly, what I found is that when I have two different hardware profiles (DOCKED and UNDOCKED) when using a docking station that my NUMLOCK state changes between the two profiles.

    Good luck.

  10. #10
    New Lounger
    Join Date
    Sep 2001
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Num Lock registry setting not persisting

    Dan, thanks for your input and kind words. I'm getting around the problem with the Windows shell VB script in my startup folder. There is not local security policy running, and the network boys say there is nothing global that should be doing this. It does not happen on other machines I use at work and at home. I did try logging in as a different user and setting the initial keyboard value to 2 and logging off/on with numlock on. No dice. As far as profiles, I have one domain and one local profile, and there is no Numlock difference between them. Since the VBS in the startup file is working, I'm not going to pursue changing policy.

    If this is my worst Windows problem, I am very fortunate. Thanks again to everyone who has made suggestions--if there are any more, I'll be happy to try them.

    Arnie

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •