Results 1 to 5 of 5
  1. #1
    Star Lounger
    Join Date
    Aug 2001
    Posts
    56
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I am working with a document that apparently has a block(s) of text marked to be excluded from spell checking. I need to find this text and remove this feature. Can't seem to find a way to do this. Any help? I'm guessing this was typed in Word 2000 or Word 2003. But need to know how to handle this problem for any versioin.

    Nancy

  2. #2
    Bronze Lounger IanWilson's Avatar
    Join Date
    Dec 2000
    Location
    Bristol, United Kingdom
    Posts
    1,523
    Thanks
    0
    Thanked 1 Time in 1 Post
    [quote name='NancyA' post='774385' date='08-May-2009 21:48']I am working with a document that apparently has a block(s) of text marked to be excluded from spell checking. I need to find this text and remove this feature. Can't seem to find a way to do this. Any help? I'm guessing this was typed in Word 2000 or Word 2003. But need to know how to handle this problem for any versioin.

    Nancy[/quote]
    Edit - Find (or Ctrl-F) brings up the find dialog. Don't put anything in the Find what box.

    Then click the More button, then Format. Choose Language from the list and put a tick in the box that says Do not check spelling or grammar.

    Click OK, then Find Next. This should find text that is marked for no proofing.

    Once you have found the text, go to Language on the Tools menu, remove the tick from that box and if necessary set the correct language.

    Ian

  3. #3
    Star Lounger
    Join Date
    Aug 2001
    Posts
    56
    Thanks
    0
    Thanked 0 Times in 0 Posts
    [quote name='IanWilson' post='774388' date='08-May-2009 21:55']Edit - Find (or Ctrl-F) brings up the find dialog. Don't put anything in the Find what box.

    Then click the More button, then Format. Choose Language from the list and put a tick in the box that says Do not check spelling or grammar.

    Click OK, then Find Next. This should find text that is marked for no proofing.

    Once you have found the text, go to Language on the Tools menu, remove the tick from that box and if necessary set the correct language.

    Ian[/quote]


    Thanks so much. I was using the Find feature but just wasn't sure how to incorporate the spelling problem.

    Nancy

  4. #4
    Plutonium Lounger
    Join Date
    Nov 2001
    Posts
    10,550
    Thanks
    0
    Thanked 7 Times in 7 Posts
    [quote name='NancyA' post='774385' date='08-May-2009 21:48']I am working with a document that apparently has a block(s) of text marked to be excluded from spell checking. I need to find this text and remove this feature. Can't seem to find a way to do this. Any help? I'm guessing this was typed in Word 2000 or Word 2003. But need to know how to handle this problem for any versioin.

    Nancy[/quote]
    If you just want to clear "Do not check spelling and grammar" then you simply need to Select All (Control-A) and then Tools > Language > clear the "Do not check spelling and grammar" flag. The flag will show as a shaded box when you first see it, showing that you have a mixed selection, but you can clear it and click OK to clear this flag for all text in the document.

  5. #5
    2 Star Lounger
    Join Date
    May 2006
    Location
    Currently in Europe
    Posts
    103
    Thanks
    7
    Thanked 0 Times in 0 Posts
    I recently replied to a similar thread, in which I described how the "Do not check spelling and grammar" setting in a style definition would remain unchanged even when the Ctrl-A method was used. In other words, changing this setting for selected text did not change the setting in the style definitions that governed the selected text. The way this appeared was when portions of a paragraph had been pasted in, thereby creating Char styles.

    Just now I tested the issue and discovered that in Word 07, the Ctrl-A method works!

    I looks to me like the new "linked styles" have made this possible. I guess their inner workings allows the language setting for selected text to override this setting in the style definition. A boon for writing in an international context - which is where we're all heading, sooner or later.

    So my advice would be: if you are running Word 07, use the Ctrl-A method. If you are running earlier versions of Word, then the search method described in this thread (which was new to me - thank you all!!) is a good start. If there are styles or Char styles containing this setting, then find the previous thread (sorry - I don't know how to link to it here!) to see advice on how to use a macro to change this setting in all the styles in the document.

    What remains to be determined is if .doc files containing Char styles, opened in Word 07, will allow the style setting to be overridden. I will have to create a test document for this, and I will report back later.
    Stylus

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •