Results 1 to 4 of 4
  1. #1
    3 Star Lounger
    Join Date
    Mar 2009
    Location
    Somewhere Over the Rainbow
    Posts
    232
    Thanks
    0
    Thanked 1 Time in 1 Post
    Hello,

    I am having trouble with how Word is breaking my page. I have attached a sample file to explain what my problem is better.
    In the attached file, you will notice it says Hello at the top, now click in the Cell where J is and make a return. Why does the Hello stay on top and the table goes to next page? I would like Word to move only the few Rows needed to the next page.

    Thanks,
    HandyAndy
    Attached Files Attached Files
    Time can fix anything.....even a broken clock. - Handy Andy

  2. #2
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts
    [quote name='HandyAndy' post='774754' date='11-May-2009 15:36']In the attached file, you will notice it says Hello at the top, now click in the Cell where J is and make a return. Why does the Hello stay on top and the table goes to next page?[/quote]
    The "H" in the first cell has the paragraph formatting attribute "Keep with Next" set. Clear that.

  3. #3
    Super Moderator
    Join Date
    Jan 2001
    Location
    Melbourne, Victoria, Australia
    Posts
    3,852
    Thanks
    4
    Thanked 259 Times in 239 Posts
    The first thing I checked is that your Table Rows are allowed to break - that was not the problem.

    The next thing to look at is the paragraph settings for all the content in the table. The problem is that the paragraph in the first cell of the row is told to keep with next (the row that starts with O). The same setting applies to the O row as well. The cascading effect is that Word tries to keep the two rows together with the empty return on after the table.

    If you look closely at the H in column A you will notice a little black square to the left of the paragraph. This indicates that there is a paragraph pagination setting on this paragraph. Select this paragraph and choose Format > Paragraph > Line and Page Breaks and remove the 'Keep with Next' setting. If you are using Word 2007 the way to get to the same dialog is to go to the Home tab on the Ribbon and click on the tiny arrow button in the bottom right of the Paragraph group.
    Andrew Lockton, Chrysalis Design, Melbourne Australia

  4. #4
    Star Lounger
    Join Date
    May 2007
    Location
    Seattle, Washington, USA
    Posts
    85
    Thanks
    0
    Thanked 2 Times in 2 Posts
    I notice that in Column A, the H and the O have the style "Heading 2" applied to them, and Heading 2 is defined to have Paragraph-KeepWithNext set. This instructs the whole "H" row to stick to the whole "O" row, and the "O" row to stick to the following paragraph. Since just one more return in the center cell makes that row, the "H" row, too big to fit on a page, it moves to the next page.

    At least that's what it looks like at first. But then on the second page, adding more returns doesn't duplicate the behavior. So I don't know what all is going on there, but changing Column A to "Normal" style (Ctrl-Shift-N) cures the immediate problem, at least on my screen.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •