Results 1 to 8 of 8
  1. #1
    5 Star Lounger
    Join Date
    May 2001
    Location
    Philadelphia, Pennsylvania
    Posts
    676
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I have what I believe is a Form Document in Word. Sorry, l know very little about Word and wish I used it more to know it better. This is an review form where one enters names, dates, and has a number of rows with "grey boxes" wehre I enter data and scores ann so on. However, when I go to run Spell CHeck, it's greyed out. Also, the text is black in a dark grey box. How do I get this "back to normal" so I can run spell check and read it easily? I have a bunch of these to do, so I'd like to make it a little easier. Would those grey boxes print? TYIA

  2. #2
    Bronze Lounger IanWilson's Avatar
    Join Date
    Dec 2000
    Location
    Bristol, United Kingdom
    Posts
    1,523
    Thanks
    0
    Thanked 1 Time in 1 Post
    [quote name='Torquemada' post='776706' date='24-May-2009 15:43']I have what I believe is a Form Document in Word. Sorry, l know very little about Word and wish I used it more to know it better. This is an review form where one enters names, dates, and has a number of rows with "grey boxes" wehre I enter data and scores ann so on. However, when I go to run Spell CHeck, it's greyed out. Also, the text is black in a dark grey box. How do I get this "back to normal" so I can run spell check and read it easily? I have a bunch of these to do, so I'd like to make it a little easier. Would those grey boxes print? TYIA[/quote]
    If the document is a form it is "protected" and a number of facilities like spell checking will be greyed out. The idea of course is that the person filling in the form has limited scope for changing things - they can only type in the fields they are intended by the document creator to fill in, and they can't change anything else. If the form was protected with a password, you'll need to know what the password is. But it may have been protected without the use of a password.

    I'm not sure what version of Word you are using, but in mine (Word 2003) you can go to the Tools menu and click on Unprotect Document. If it needs a password it will ask for it. You can then do what you like with the document and protect it again afterwards.

    The grey background in the fields is controllable - see the screenshot below of the Help item on this.

    [attachment=83937:Form_shading.jpg]

    Does this help?

    Ian
    Attached Images Attached Images

  3. #3
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts
    You need a macro to spell check a document protected for forms. See How to enable the spellchecker in a protected document.

  4. #4
    5 Star Lounger
    Join Date
    May 2001
    Location
    Philadelphia, Pennsylvania
    Posts
    676
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Thanks! The form was not password protected and I am able to spell check. Will keep the macro for future use. However, now that I have run Spellcheck, and I want to add some text to the boxes, when I try and click the boxes, the whole box is selected and I cannot get into the text to change things. What a nuisance. I hesitate to reinstate Protection because I cannot interpret what the checkboxes would do.

  5. #5
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts
    The easiest way to toggle protection on and off is to click the "lock" button on the Forms toolbar. This has the added advantage that it preserves the content of already filled-in form fields.

  6. #6
    5 Star Lounger
    Join Date
    May 2001
    Location
    Philadelphia, Pennsylvania
    Posts
    676
    Thanks
    0
    Thanked 0 Times in 0 Posts
    [quote name='HansV' post='777018' date='26-May-2009 11:00']The easiest way to toggle protection on and off is to click the "lock" button on the Forms toolbar. This has the added advantage that it preserves the content of already filled-in form fields.[/quote]
    Ok, i put up the toolbar; it is handy. But when I run spellcheck with protection off, I am told everything is OK. Yet I see obvious errors, even when I select the whole document and F7 it again.

  7. #7
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts
    The form fields have probably been set to "Do not check spelling or grammar" automatically. Try the following:
    - Make sure that the document is not protected.
    - Press Ctrl+A to select the entire document.
    - Select Tools | Language | Set Language...
    - Click the check box "Do not check spelling or grammar" until it has been cleared.
    - Click OK.
    Now start the spell check again.

  8. #8
    Super Moderator
    Join Date
    May 2002
    Location
    Canberra, Australian Capital Territory, Australia
    Posts
    5,055
    Thanks
    2
    Thanked 417 Times in 346 Posts
    [quote name='HansV' post='777022' date='27-May-2009 01:45']The form fields have probably been set to "Do not check spelling or grammar" automatically. Try the following:
    - Make sure that the document is not protected.
    - Press Ctrl+A to select the entire document.
    - Select Tools | Language | Set Language...
    - Click the check box "Do not check spelling or grammar" until it has been cleared.
    - Click OK.
    Now start the spell check again.[/quote]
    Ideally, the whole document should be set to 'no proofing', then reset just the appropriate formfields (eg not including names & addresses) to allow proofing. That way, the spell check's action is limited to just the user-data that might require it. You wouldn't want the user being prompted to 'correct' anything else ...
    Cheers,

    Paul Edstein
    [MS MVP - Word]

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •